aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-06-19 11:23:23 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:15:41 +0200
commit78369eab12488cf796d71e5c3c3d1ffccbf33457 (patch)
tree41915612ceeb9bbd90e37131405978613d6cb3b9
parentfebd96e7c29cdeb08a0cdf9148b1c5bae6062cdb (diff)
downloadguix-78369eab12488cf796d71e5c3c3d1ffccbf33457.tar
guix-78369eab12488cf796d71e5c3c3d1ffccbf33457.tar.gz
gnu: Add texlive-mpcolornames.
* gnu/packages/tex.scm (texlive-mpcolornames): New variable.
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 707738e778..c131873c6b 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -5702,6 +5702,29 @@ heads to be used with MetaPost commands")
using the Pattern Color Space available in PostScript Level 2.")
(license license:public-domain)))
+(define-public texlive-mpcolornames
+ (package
+ (name "texlive-mpcolornames")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/metapost/mpcolornames/"
+ "metapost/mpcolornames/"
+ "source/metapost/mpcolornames/")
+ (base32
+ "1s5yb57yamg1fd7w5hmkmfyxyqj3mivhkvrkqzm31dzh4y22qg3k")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/mpcolornames")
+ (synopsis "Extend list of predefined colour names for MetaPost")
+ (description
+ "The MetaPost format @code{plain.mp} provides only five built-in colour names
+(variables), all of which are defined in the RGB model: red, green and blue
+for the primary colours and black and white. The package makes more than 500
+colour names from different colour sets in different colour models available
+to MetaPost.")
+ (license license:lppl)))
+
(define-public texlive-natbib
(package
(name "texlive-natbib")