aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authoremma thompson <bigbookofbug@proton.me>2024-10-15 17:51:04 +0000
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2024-10-24 15:10:42 +0200
commit77b73b61fc214a671c274d8cc77d123e947a48be (patch)
treede518e2c106716517fdee0381f0b42767eb36ff5
parent6eca624cfbc8598c32394e8f16136f9002523bde (diff)
downloadguix-77b73b61fc214a671c274d8cc77d123e947a48be.tar
guix-77b73b61fc214a671c274d8cc77d123e947a48be.tar.gz
gnu: Add emacs-catppuccin-theme.
* gnu/packages/emacs-xyz.scm (emacs-catppuccin-theme): New variable. Change-Id: I0a8deb9cd88a7ea38615ee0db96e0707a4c3cf2a Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/emacs-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index b26f84743e..ca77975ac7 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -146,6 +146,7 @@
;;; Copyright © 2024 Ashish SHUKLA <ashish.is@lostca.se>
;;; Copyright © 2024 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;; Copyright © 2024 Spencer King <spencer.king@nursiapress.com>
+;;; Copyright © 2024 emma thompson <bigbookofbug@proton.me>
;;;
;;; This file is part of GNU Guix.
@@ -2167,6 +2168,30 @@ then only the color of the mode line changes when a window becomes in-/active.")
inspired by Plan 9 Acme and the Sam text editor.")
(license license:gpl3+))))
+(define-public emacs-catppuccin-theme
+ (let ((commit "4441d5114fdcc2eb05186a974b4bbad7224e43b5")
+ (revision "1"))
+ (package
+ (name "emacs-catppuccin-theme")
+ (version (git-version "1.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/catppuccin/emacs")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1y2ads0w5l3mm0mxxbi2ppb6csq8hw2fd9cmak3myv13qzw92x3w"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/catppuccin/emacs")
+ (synopsis "Soothing pastel theme for Emacs")
+ (description
+ "Catppuccin is a soothing pastel theme for Emacs. It provides
+different color palettes, such as @samp{frappe}, @samp{macchiato}, or
+@samp{latte}.")
+ (license license:expat))))
+
(define-public emacs-theme-magic
;; No tagged release upstream, but the commit below correspond to the 0.2.3
;; release.