aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-04-26 17:26:53 +0300
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:45:01 +0200
commit77192e834b81cc6622ce755fd7e515528d278dbc (patch)
tree881bca9042a6f4cd9be22bca83bc4cf849e3a026
parent0bae9e17c681bec70424f921e004808b390fe892 (diff)
downloadguix-77192e834b81cc6622ce755fd7e515528d278dbc.tar
guix-77192e834b81cc6622ce755fd7e515528d278dbc.tar.gz
gnu: icedtea-8: Fix building.
* gnu/packages/java.scm (icedtea-8)[arguments]: Replace 'build phase to not pass '-j' to make. Change-Id: Ifc5c99f33bb75bb52212aa32d0bbd10f4bce83a4
-rw-r--r--gnu/packages/java.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index b3b037ea43..b6d8aa32cb 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -763,6 +763,10 @@ IcedTea build harness.")
(delete 'patch-patches)
(delete 'patch-bitrot)
(delete 'use-classpath)
+ ;; Prevent passing -j (parallel-job-count) to make
+ (replace 'build
+ (lambda* (#:key (make-flags '()) #:allow-other-keys)
+ (apply invoke "make" make-flags)))
;; Prevent the keytool from recording the current time when
;; adding certificates at build time.
(add-after 'unpack 'patch-keystore