aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-19 21:46:03 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-25 21:00:58 +0100
commit770a66850530df05c967b8ce47109843cd343a64 (patch)
treec5f90c781a688434514c0cda8af80ea16f29bc6c
parent1775f91de29e8c7e0531c6ee05fc832fdb919a21 (diff)
downloadguix-770a66850530df05c967b8ce47109843cd343a64.tar
guix-770a66850530df05c967b8ce47109843cd343a64.tar.gz
gnu: go-github-com-google-go-cmp-cmp: Improve package style.
* gnu/packages/golang.scm (go-github-com-google-go-cmp-cmp): Adjust indentation. [arguments]: Apply new package list style and G-expressions. [home-page]: Move after [synopsis]. Change-Id: I14a8dfcbe8a17c98df7f880823cd9c35522f013b
-rw-r--r--gnu/packages/golang.scm43
1 files changed, 22 insertions, 21 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 4cecefc5a3..a5d199df2c 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5933,33 +5933,34 @@ filters for Go.")
(package
(name "go-github-com-google-go-cmp-cmp")
(version "0.6.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/google/go-cmp")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1n1j4hi50bl05pyys4i7y417k9g6k1blslj27z327qny7kkdl2ma"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/google/go-cmp")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1n1j4hi50bl05pyys4i7y417k9g6k1blslj27z327qny7kkdl2ma"))))
(build-system go-build-system)
(arguments
- '(#:import-path "github.com/google/go-cmp/cmp"
- #:unpack-path "github.com/google/go-cmp"
- #:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key inputs #:allow-other-keys #:rest args)
- (unless
- ;; The tests fail when run with gccgo.
- (false-if-exception (search-input-file inputs "/bin/gccgo"))
- (apply (assoc-ref %standard-phases 'check) args)))))))
+ (list
+ #:import-path "github.com/google/go-cmp/cmp"
+ #:unpack-path "github.com/google/go-cmp"
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key inputs #:allow-other-keys #:rest args)
+ (unless
+ ;; The tests fail when run with gccgo.
+ (false-if-exception (search-input-file inputs "/bin/gccgo"))
+ (apply (assoc-ref %standard-phases 'check) args)))))))
(synopsis "Determine equality of values in Go")
+ (home-page "https://github.com/google/go-cmp")
(description
"This package is intended to be a more powerful and safer
-alternative to @@code{reflect.DeepEqual} for comparing whether two values are
+alternative to @code{reflect.DeepEqual} for comparing whether two values are
semantically equal.")
- (home-page "https://github.com/google/go-cmp")
(license license:bsd-3)))
(define-public go-github-com-google-uuid