aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjgart <jgart@dismail.de>2024-07-11 21:49:59 -0500
committerjgart <jgart@dismail.de>2024-07-11 21:50:38 -0500
commit74ed0a9f15148e3267a5a0962842b2b1d40c41d3 (patch)
tree117522bf4fd6f3baa4dfdb4560832adf2cd6ab15
parentfb11149feaa177a95e1f0d640e4f03881257e83e (diff)
downloadguix-74ed0a9f15148e3267a5a0962842b2b1d40c41d3.tar
guix-74ed0a9f15148e3267a5a0962842b2b1d40c41d3.tar.gz
gnu: python-pytelegrambotapi: Use new style.
* gnu/packages/python-xyz.scm (python-pytelegrambotapi) [arguments]: Use new style. Change-Id: Id31d34d9c09330f7a5aa723ca1a1352b6736d875
-rw-r--r--gnu/packages/python-xyz.scm16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3e0c8a976a..cc83c72dd2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2083,14 +2083,14 @@ task of adding retry behavior to just about anything.")
(base32 "0r7g5zs0fk3g2dxvbpl0pi730x7r2kalrhn30fs0pvc15a59fmxz"))))
(build-system python-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (with-directory-excursion "tests"
- (invoke "py.test")))
- #t)))))
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion "tests"
+ (invoke "py.test"))))))))
(propagated-inputs
(list python-requests))
(native-inputs