aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Hodina <phodina@protonmail.com>2022-12-03 10:21:45 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-04-23 19:00:54 +0200
commit74e96c4cb171b17949f638d8b452d047a8f2dc6f (patch)
treeb042b724ec613f6e23ae65d42a7e9d8e73d82558
parent0fa6c6fdd3f4df52fcce27e139da65cd06bccc15 (diff)
downloadguix-74e96c4cb171b17949f638d8b452d047a8f2dc6f.tar
guix-74e96c4cb171b17949f638d8b452d047a8f2dc6f.tar.gz
gnu: Add lxi-tools.
* gnu/packages/hardware.scm (lxi-tools): New variable. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/hardware.scm50
1 files changed, 50 insertions, 0 deletions
diff --git a/gnu/packages/hardware.scm b/gnu/packages/hardware.scm
index fdb7be3185..5b85ad9b2e 100644
--- a/gnu/packages/hardware.scm
+++ b/gnu/packages/hardware.scm
@@ -64,6 +64,7 @@
#:use-module (gnu packages high-availability)
#:use-module (gnu packages libusb)
#:use-module (gnu packages linux)
+ #:use-module (gnu packages lua)
#:use-module (gnu packages lxqt)
#:use-module (gnu packages mtools)
#:use-module (gnu packages package-management)
@@ -83,6 +84,7 @@
#:use-module (gnu packages qt)
#:use-module (gnu packages scanner)
#:use-module (gnu packages security-token)
+ #:use-module (gnu packages readline)
#:use-module (gnu packages tls)
#:use-module (gnu packages video)
#:use-module (gnu packages virtualization)
@@ -1388,3 +1390,51 @@ confused with the @code{cpuid} command line utility from package @code{cpuid}.")
based on the LXI Consortium standard which defines the communication protocols
for modern instrumentation and data acquision systems using Ethernet.")
(license license:bsd-3)))
+
+(define-public lxi-tools
+ (package
+ (name "lxi-tools")
+ (version "2.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/lxi-tools/lxi-tools")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1xc99xhca386az73rpsrf3z0j7y0hrv0xcwj1dr2ahr7lhnjznqp"))))
+ (build-system meson-build-system)
+ (arguments
+ (list
+ #:glib-or-gtk? #true
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'skip-gtk-update-icon-cache
+ (lambda _
+ (substitute* "build-aux/meson/postinstall.py"
+ (("gtk-update-icon-cache") (which "true"))
+ (("update-desktop-database") (which "true"))))))))
+ (native-inputs
+ (list bash-completion
+ cmake
+ (list glib "bin")
+ pkg-config
+ python
+ readline))
+ (inputs
+ (list glib
+ gtk
+ gtksourceview
+ json-glib
+ libadwaita
+ liblxi
+ lua))
+ (home-page "https://lxi-tools.github.io/")
+ (synopsis "LAN eXtensions for Instrumentation tools")
+ (description
+ "This package provides tools for LAN eXtensions for Instrumentation based
+on the LXI Consortium standard which defines the communication protocols for
+modern instrumentation and data acquision systems using Ethernet.")
+ (license license:bsd-3)))