aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorng0 <ng0@we.make.ritual.n0.is>2016-09-18 13:16:23 +0000
committerEfraim Flashner <efraim@flashner.co.il>2016-10-09 13:09:31 +0300
commit73acc19334b9bdd782fd88233959dc7f2114a304 (patch)
tree1dc6dd26f12ab13152baf3881aa8f950bfb9f6f6
parentbc1c995e6ed7bde9a5c12fa66ea805485690afb1 (diff)
downloadguix-73acc19334b9bdd782fd88233959dc7f2114a304.tar
guix-73acc19334b9bdd782fd88233959dc7f2114a304.tar.gz
gnu: Add python-socksipy-branch.
* gnu/packages/python.scm (python-socksipy-branch): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/python.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index c7d9e6fc12..a9fd8eb4a9 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -3736,6 +3736,34 @@ routines such as routines for numerical integration and optimization.")
(define-public python2-scipy
(package-with-python2 python-scipy))
+(define-public python-socksipy-branch
+ (package
+ (name "python-socksipy-branch")
+ (version "1.01")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "SocksiPy-branch" version))
+ (sha256
+ (base32
+ "01l41v4g7fy9fzvinmjxy6zcbhgqaif8dhdqm4w90fwcw9h51a8p"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:tests? #f)) ; There are no tests
+ (home-page "https://code.google.com/archive/p/socksipy-branch/")
+ (synopsis "Python SOCKS module")
+ (description
+ "SocksiPy - A Python SOCKS client module. It provides a
+socket-like interface that supports connections to any TCP
+service through the use of a SOCKS4, SOCKS5 or HTTP proxy.
+The original version was developed by Dan Haim, this is a
+branch created by Mario Vilas to address some open issues,
+as the original project seems to have been abandoned circa 2007.")
+ (license license:bsd-3)))
+
+(define-public python2-socksipy-branch
+ (package-with-python2 python-socksipy-branch))
+
(define-public python-sqlalchemy
(package
(name "python-sqlalchemy")