aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2024-04-20 00:20:00 +0200
committerRicardo Wurmus <rekado@elephly.net>2024-04-22 11:29:30 +0200
commit7244fb26bd155e5c04601029b7774b8defbe64aa (patch)
tree27c26195c0eb32c2a0c86a261cd4eb849b1498f0
parent061c7bc1cac93841b616bf07be56fe91abe579be (diff)
downloadguix-7244fb26bd155e5c04601029b7774b8defbe64aa.tar
guix-7244fb26bd155e5c04601029b7774b8defbe64aa.tar.gz
gnu: cpplint: Use pyproject-build-system.
* gnu/packages/cpp.scm (cpplint)[build-system]: Use pyproject-build-system. [arguments]: Remove custom 'check phase. Change-Id: I270de2cafe75ef2d7280dee884a0aeb060f2aa32
-rw-r--r--gnu/packages/cpp.scm13
1 files changed, 5 insertions, 8 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 77083e9a19..8a0bd62d6b 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -67,6 +67,7 @@
#:use-module (guix build-system gnu)
#:use-module (guix build-system meson)
#:use-module (guix build-system python)
+ #:use-module (guix build-system pyproject)
#:use-module (guix build-system scons)
#:use-module (guix modules)
#:use-module (guix gexp)
@@ -1156,12 +1157,13 @@ library.")
(sha256
(base32 "13l86aq0h1jga949k79k9x3hw2xqchjc162sclg2f99vz98zcz15"))
(file-name (git-file-name name version))))
+ (build-system pyproject-build-system)
(arguments
(list #:modules `((srfi srfi-1)
(srfi srfi-26)
- ,@%python-build-system-modules)
+ ,@%pyproject-build-system-modules)
#:phases
- #~(modify-phases (@ (guix build python-build-system) %standard-phases)
+ #~(modify-phases (@ (guix build pyproject-build-system) %standard-phases)
(add-before 'wrap 'reduce-GUIX_PYTHONPATH
(lambda _
;; Hide the transitive native inputs from GUIX_PYTHONPATH
@@ -1185,12 +1187,7 @@ library.")
(add-after 'wrap 'reset-GUIX_PYTHONPATH
(lambda _
(setenv "GUIX_PYTHONPATH"
- (getenv "TMP_PYTHONPATH"))))
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-vv")))))))
- (build-system python-build-system)
+ (getenv "TMP_PYTHONPATH")))))))
(native-inputs
(list python-coverage
python-pytest