aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2020-06-17 16:21:43 -0700
committerEfraim Flashner <efraim@flashner.co.il>2020-11-22 19:44:37 +0200
commit723a981194653131605c0248f3d5a57d41c1b438 (patch)
treecb93d80df7c507d20ad5ea81b36e2c943249dadb
parent531f0f933a50467a8e648e76f955ae39b41e3c2e (diff)
downloadguix-723a981194653131605c0248f3d5a57d41c1b438.tar
guix-723a981194653131605c0248f3d5a57d41c1b438.tar.gz
gnu: Add rust-progrs-0.1.
* gnu/packages/crates-io.scm (rust-progrs-0.1): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/crates-io.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 3ed58efd03..32391525e3 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -20008,6 +20008,38 @@ macro use case.")
@code{proc_macro_derive} pretend to be @code{proc_macro}.")
(license (list license:expat license:asl2.0))))
+(define-public rust-progrs-0.1
+ (package
+ (name "rust-progrs")
+ (version "0.1.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "progrs" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "108jx8jrv2r1brhvbqfw6fwx298k5fnw3m46kn7lv0jx2wmf0ifz"))))
+ (build-system cargo-build-system)
+ (arguments '(#:tests? #f))
+ (home-page "https://nest.pijul.com/laumann/progrs")
+ (synopsis "Small library for displaying compact progress bars")
+ (description
+ "There are a number of libraries out there that can be used for progress
+display, but in the author's opinion these libraries do it almost right -
+either they eat up too much screen real estate (by not sticking to one line
+per thing that should use progress) or they try to align stuff left and right.
+
+In the author's humble opinion, the best example of just the right amount of
+information vs screen real-estate is in the Git progress output (when cloning,
+pulling, etc). It uses one line per thing, and may display both percentage
+complete (in cases where it's known) and even throughput (for network
+transfer).
+
+This library mimics the Git way of showing progress.")
+ (license license:gpl2+)))
+
(define-public rust-proptest-0.9
(package
(name "rust-proptest")