aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-20 16:56:29 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-25 21:00:59 +0100
commit6f80521c7edd0d5f306408c9373b6dad7de0fe8e (patch)
treea632dca8a5362c030b412ddb5d596cd478341491
parent1528b458739065e4e8591d7ef8afbb5707b58a43 (diff)
downloadguix-6f80521c7edd0d5f306408c9373b6dad7de0fe8e.tar
guix-6f80521c7edd0d5f306408c9373b6dad7de0fe8e.tar.gz
gnu: go-golang-org-sql-mock: Refresh package style.
* gnu/packages/golang-check.scm (go-golang-org-sql-mock): Fix indentation. Apply list style. [source]: Remove snippet. [arguments]: <#:phases>: Add 'remove-example phase. [home-page]: Place before [synopsis]. [description]: Start from a new line. Change-Id: Idbe31ee6a9ffe8d3d2ae4479c39f523531258bca
-rw-r--r--gnu/packages/golang-check.scm51
1 files changed, 28 insertions, 23 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index aea2639293..05c37102f2 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -1065,29 +1065,34 @@ under test) much simpler.")
(license license:asl2.0)))
(define-public go-golang-org-sql-mock
- (package
- (name "go-golang-org-sql-mock")
- (version "1.5.2")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/DATA-DOG/go-sqlmock")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1vpvdx9hwmx9gm27aq5r5219xpaxz0gy4q1iqskk4saz05bspn0f"))
- (modules '((guix build utils)))
- (snippet '(delete-file-recursively "examples"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/DATA-DOG/go-sqlmock"))
- (synopsis "Mock library implementing @code{sql/driver}")
- (description "This library simulates SQL-driver behavior in tests
-without requiring a real database connection.")
- (home-page "https://github.com/DATA-DOG/go-sqlmock")
- (license license:expat)))
+ (package
+ (name "go-golang-org-sql-mock")
+ (version "1.5.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/DATA-DOG/go-sqlmock")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1vpvdx9hwmx9gm27aq5r5219xpaxz0gy4q1iqskk4saz05bspn0f"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/DATA-DOG/go-sqlmock"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'remove-examples
+ (lambda* (#:key import-path #:allow-other-keys)
+ (delete-file-recursively
+ (string-append "src/" import-path "/examples")))))))
+ (home-page "https://github.com/DATA-DOG/go-sqlmock")
+ (synopsis "Mock library implementing @code{sql/driver}")
+ (description
+ "This library simulates SQL-driver behavior in tests without requiring a
+real database connection.")
+ (license license:expat)))
(define-public go-golang-org-x-lint
(let ((commit "83fdc39ff7b56453e3793356bcff3070b9b96445")