aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-10-20 15:51:25 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-10-30 19:32:15 +0000
commit6ec8ad1551debc35183e7420eabb2d7ff6422e6b (patch)
treec3fdc262d2e6c98b6f023e76a951b918dec99771
parent1e2534fe396f8444e4c150cd5ab28c829a901da3 (diff)
downloadguix-6ec8ad1551debc35183e7420eabb2d7ff6422e6b.tar
guix-6ec8ad1551debc35183e7420eabb2d7ff6422e6b.tar.gz
gnu: python-glymur: Update to 0.13.6.
* gnu/packages/python-xyz.scm (python-glymur): Update to 0.13.6. [phases]: Remove 'disable-failing-tests and move the logic to <#:tests-flags>. [native-inputs]: Add python-setuptools and python-wheel. Change-Id: Ied56e22d938b7cc61969892b680c9e72d1cfce1e
-rw-r--r--gnu/packages/python-xyz.scm21
1 files changed, 10 insertions, 11 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7e7442b2a3..b11a33fa52 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2279,7 +2279,7 @@ Python library and command line interface.")
(define-public python-glymur
(package
(name "python-glymur")
- (version "0.13.5")
+ (version "0.13.6")
(source
(origin
(method git-fetch) ; no tests data in PyPi package
@@ -2288,12 +2288,15 @@ Python library and command line interface.")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1n2n7bj5w29w5y2gcl4hxhqf85n0j2crkln9i0mprq3xw8finxpx"))))
+ (base32 "06v6g0fwzmy2imhrvy0q4zrhrlrp24yhs098vi13r92ga63c72xl"))))
(build-system pyproject-build-system)
(arguments
(list
#:test-flags
- #~(list "-n" "auto")
+ #~(list "--numprocesses" "auto"
+ ;; Failing test due to inability of ctypes.util.find_library()
+ ;; to determine library path, which is patched above.
+ "--ignore=tests/test_config.py")
#:phases
#~(modify-phases %standard-phases
(add-after 'unpack 'patch-library-locations
@@ -2311,17 +2314,13 @@ Python library and command line interface.")
(search-input-file inputs "/lib/libtiff.so") "\"\n"
" elif libname == \"c\":\n"
" path = \""
- (search-input-file inputs "/lib/libc.so.6") "\"\n")))))
- (add-before 'check 'disable-failing-tests
- (lambda _
- ;; Failing test due to inability of
- ;; ctypes.util.find_library() to determine library path,
- ;; which is patched above.
- (delete-file "tests/test_config.py"))))))
+ (search-input-file inputs "/lib/libc.so.6") "\"\n"))))))))
(native-inputs
(list python-pytest
python-pytest-xdist
- python-scikit-image))
+ python-scikit-image
+ python-setuptools
+ python-wheel))
(inputs
(list openjpeg ; glymur/lib/openjp2.py
libtiff)) ; glymur/lib/tiff.py