aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-26 13:14:53 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-26 17:02:42 +0100
commit6cf5896b03b08234becbcc64edd66771bc87c1a9 (patch)
tree6e8fcc6b0607e36db65458a15354733cbcddd062
parent51679b4a9a43349f5243211f056c4e6bb7e0b440 (diff)
downloadguix-6cf5896b03b08234becbcc64edd66771bc87c1a9.tar
guix-6cf5896b03b08234becbcc64edd66771bc87c1a9.tar.gz
gnu: Add go-keyring.
* gnu/packages/golang-crypto.scm (go-keyring): New variable. Change-Id: I492e1724ecaef9d6819d99be0aff8ee5a3d72b13
-rw-r--r--gnu/packages/golang-crypto.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index fe6ce11398..d4509009fa 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -1547,6 +1547,20 @@ Go.")
#:unpack-path "filippo.io/age"
#:install-source? #f))))
+(define-public go-keyring
+ (package
+ (inherit go-github-com-99designs-keyring)
+ (name "go-keyring")
+ (arguments
+ (list
+ #:install-source? #f
+ #:import-path "github.com/99designs/keyring/cmd/keyring"
+ #:unpack-path "github.com/99designs/keyring"))
+ (description
+ (string-append (package-description go-github-com-99designs-keyring)
+ " This package provides an command line interface (CLI)
+tool."))))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar