aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-07 12:31:11 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-03 22:23:22 +0100
commit6bfa7ccb23c9baab73d6aa54029515af4dd24021 (patch)
tree9c2a69ce0b8dc94f3d1cbdb572e1aa2b448c51cd
parent190762728990801f40eb55e1cfd4b0f59cc836ee (diff)
downloadguix-6bfa7ccb23c9baab73d6aa54029515af4dd24021.tar
guix-6bfa7ccb23c9baab73d6aa54029515af4dd24021.tar.gz
gnu: Add go-tengo.
* gnu/packages/golang-xyz.scm (go-tengo): New variable. Change-Id: I8fb24d0bdd4eccb2da5f584edfec9b9ba1a9c4d5
-rw-r--r--gnu/packages/golang-xyz.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index d3afae5441..0208063845 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -4659,6 +4659,20 @@ go-github-com-tklauser-numcpus source.")))
"This package provides a CLI build from the
go-github-com-orisano-pixelmatch source.")))
+(define-public go-tengo
+ (package
+ (inherit go-github-com-d5-tengo-v2)
+ (name "tengo")
+ (arguments
+ (list
+ #:import-path "github.com/d5/tengo/cmd/tengo"
+ #:unpack-path "github.com/d5/tengo"
+ #:install-source? #f))
+ (description
+ (string-append (package-description go-github-com-d5-tengo-v2)
+ "\nThis package provides an command line interface (CLI)
+tool."))))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar