aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2023-06-18 12:15:09 +0100
committerChristopher Baines <mail@cbaines.net>2023-06-20 22:04:51 +0100
commit6bafbfd40ff9d1066ec4041b37f90cd34de5a099 (patch)
tree6524c535c052c5dfbef54f6bf9c6c546896614b5
parent7c5d30eb9f05c5b0b1e3032019148091c33a1513 (diff)
downloadguix-6bafbfd40ff9d1066ec4041b37f90cd34de5a099.tar
guix-6bafbfd40ff9d1066ec4041b37f90cd34de5a099.tar.gz
gnu: ruby-commander: Update to 4.6.0.
* gnu/packages/ruby.scm (ruby-commander): Update to 4.6.0. [arguments]: Update style.
-rw-r--r--gnu/packages/ruby.scm26
1 files changed, 13 insertions, 13 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 369d6f44ed..3c27f1e6a1 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -321,27 +321,27 @@ matching. mruby can be linked and embedded within your application.")
(define-public ruby-commander
(package
(name "ruby-commander")
- (version "4.4.7")
+ (version "4.6.0")
(source
(origin
(method url-fetch)
(uri (rubygems-uri "commander" version))
(sha256
(base32
- "1pxakz596fjqak3cdbha6iva1dlqis86i3kjrgg6lf3sp8i5vhwg"))))
+ "1n8k547hqq9hvbyqbx2qi08g0bky20bbjca1df8cqq5frhzxq7bx"))))
(build-system ruby-build-system)
(arguments
- `(#:test-target "spec"
- #:phases
- (modify-phases %standard-phases
- ;; Don't run or require rubocop, the code linting tool, as this is a
- ;; bit unnecessary.
- (add-after 'unpack 'dont-run-rubocop
- (lambda _
- (substitute* "Rakefile"
- ((".*rubocop.*") "")
- ((".*RuboCop.*") ""))
- #t)))))
+ (list
+ #:test-target "spec"
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; Don't run or require rubocop, the code linting tool, as this is a
+ ;; bit unnecessary.
+ (add-after 'unpack 'dont-run-rubocop
+ (lambda _
+ (substitute* "Rakefile"
+ ((".*rubocop.*") "")
+ ((".*RuboCop.*") "")))))))
(propagated-inputs
(list ruby-highline))
(native-inputs