aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authornormalmente <normally_js@posteo.net>2024-03-20 18:55:50 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-03-23 20:58:33 +0000
commit68455ddf4b5142c6b9d3b4b85248d6a07a049bca (patch)
tree34a207e371380855c4bd4e6d8853f188450a467e
parentfd579def37e638799ab8dff2d0d0fbb397ccaa36 (diff)
downloadguix-68455ddf4b5142c6b9d3b4b85248d6a07a049bca.tar
guix-68455ddf4b5142c6b9d3b4b85248d6a07a049bca.tar.gz
gnu: magic-wormhole: Update to 0.13.0.
* gnu/packages/magic-wormhole.scm (magic-wormhole): Update to 0.13.0. [native-inputs]: Add python-noiseprotocol to make tests pass. Change-Id: I59008f27081efcc3b558dad59bef6ebdc9b34f38 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/magic-wormhole.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/magic-wormhole.scm b/gnu/packages/magic-wormhole.scm
index 86a8013aa1..f9ccf8c1d3 100644
--- a/gnu/packages/magic-wormhole.scm
+++ b/gnu/packages/magic-wormhole.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2019 Leo Famulari <leo@famulari.name>
+;;; Copyright © 2024 normally_js <normally_js@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -106,14 +107,14 @@ together, allowing them to pretend they have a direct connection.")
(define-public magic-wormhole
(package
(name "magic-wormhole")
- (version "0.12.0")
+ (version "0.13.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "magic-wormhole" version))
(sha256
(base32
- "0q41j99718y7m95zg1vaybnsp31lp6lhyqkbv4yqz5ys6jixh3qv"))))
+ "05hm5pnrxli69a28h3pbgx6s6pwy8279l506kha7y3i7hs1dcfxc"))))
(build-system python-build-system)
(arguments
'(#:phases
@@ -128,6 +129,7 @@ together, allowing them to pretend they have a direct connection.")
#t)))))
(native-inputs
(list python-mock
+ python-noiseprotocol
;; XXX These are required for the test suite but end up being referenced
;; by the built package.
;; https://bugs.gnu.org/25235