aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-27 23:45:56 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-28 01:05:16 +0100
commit6593f40b77440c6680dbb828fc573897d4949b73 (patch)
treec1409e93569675a50323539f9a2c16822efac3d5
parent190c0abec86ae2d007330ed226033413997c1004 (diff)
downloadguix-6593f40b77440c6680dbb828fc573897d4949b73.tar
guix-6593f40b77440c6680dbb828fc573897d4949b73.tar.gz
gnu: Add go-git-sr-ht-rockorager-go-jmap.
* gnu/packages/golang-web.scm (go-git-sr-ht-rockorager-go-jmap): New variable. Change-Id: I1445fda30635ee6132f9d6ea628980445c1ab133
-rw-r--r--gnu/packages/golang-web.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index f1bf859224..0bea9afb7d 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -130,6 +130,44 @@ API service accounts for Go.")
"This package provides a GraphQL client and code generator for Go.")
(license license:expat)))
+(define-public go-git-sr-ht-rockorager-go-jmap
+ (package
+ (name "go-git-sr-ht-rockorager-go-jmap")
+ (version "0.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~rockorager/go-jmap")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1r8bmdlmvpk08i7xrqwgv0aaz05564wgcyji73nszdh2s32m4kzl"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "git.sr.ht/~rockorager/go-jmap"
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; XXX: Workaround for go-build-system's lack of Go modules support.
+ (replace 'check
+ (lambda* (#:key tests? import-path #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion (string-append "src/" import-path)
+ (invoke "go" "test" "-v" "./..."))))))))
+ (native-inputs
+ (list
+ go-github-com-stretchr-testify))
+ (propagated-inputs
+ (list go-golang-org-x-oauth2))
+ (home-page "https://git.sr.ht/~rockorager/go-jmap")
+ (synopsis "JSON meta application protocol in Golang")
+ (description
+ "Package jmap implements JMAP Core protocol as defined in
+@@url{https://rfc-editor.org/rfc/rfc8620.html,RFC 8620} published on July
+2019.")
+ (license license:expat)))
+
(define-public go-github-com-alexliesenfeld-health
(package
(name "go-github-com-alexliesenfeld-health")