aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKristian Trandem <kristian@devup.no>2019-08-16 02:35:39 +0200
committerMarius Bakke <marius@gnu.org>2020-11-21 01:21:31 +0100
commit65579957d524804ea27dec2bed4382aa00a607e2 (patch)
tree3da0045a5a1de5c7e39c8fd40092243b264257a1
parent2920e8841341909ff570f8544e14e35fabbf8556 (diff)
downloadguix-65579957d524804ea27dec2bed4382aa00a607e2.tar
guix-65579957d524804ea27dec2bed4382aa00a607e2.tar.gz
gnu: Add python-boto3.
gnu/packages/python-xyz.scm (python-boto3): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/python-xyz.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index b55c882d07..6605cde6b4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -91,6 +91,7 @@
;;; Copyright © 2020 Ekaitz Zarraga <ekaitz@elenq.tech>
;;; Copyright © 2020 Diego N. Barbato <dnbarbato@posteo.de>
;;; Copyright © 2020 Leo Prikler <leo.prikler@student.tugraz.at>
+;;; Copyright © 2019 Kristian Trandem <kristian@devup.no>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -11028,6 +11029,40 @@ interface to the Amazon Web Services (AWS) API.")
(define-public python2-botocore
(package-with-python2 python-botocore))
+(define-public python-boto3
+ (package
+ (name "python-boto3")
+ (version "1.16.22")
+ (home-page "https://github.com/boto/boto3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference (url home-page) (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0h20hgl4yfl58g75qhb6ibrdmzn47md3srgar7hask14cjmfhfy3"))))
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'delete-network-tests
+ ;; Deleting integration tests because they are trying to connect to AWS.
+ (lambda _
+ (delete-file-recursively "tests/integration")
+ #t)))))
+ (build-system python-build-system)
+ (native-inputs
+ `(("python-nose" ,python-nose)
+ ("python-mock" ,python-mock)))
+ (propagated-inputs
+ `(("python-botocore" ,python-botocore)
+ ("python-jmespath" ,python-jmespath)
+ ("python-s3transfer" ,python-s3transfer)))
+ (synopsis "AWS SDK for Python")
+ (description
+ "Boto3 is a Python library for writing programs that interact with
+@acronym{AWS,Amazon Web Services}.")
+ (license license:asl2.0)))
+
(define-public python-pyfiglet
(package
(name "python-pyfiglet")