aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2023-09-14 14:15:35 +0200
committerAndrew Tropin <andrew@trop.in>2023-09-15 13:35:44 +0400
commit61a89de7d7e6517cd393dd1f3cf93004a5a3bdf2 (patch)
tree2455ffda814f1363f0ce5f585ac50df295a206e9
parenta0510561935e3327099df558e9dd9bdffe850441 (diff)
downloadguix-61a89de7d7e6517cd393dd1f3cf93004a5a3bdf2.tar
guix-61a89de7d7e6517cd393dd1f3cf93004a5a3bdf2.tar.gz
gnu: emacs-sway: Update to 0.7.
* gnu/packages/emacs-xyz.scm (emacs-sway): Update to 0.7. Signed-off-by: Andrew Tropin <andrew@trop.in>
-rw-r--r--gnu/packages/emacs-xyz.scm39
1 files changed, 18 insertions, 21 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index a4c6f45feb..c4de0e1d1f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -12440,30 +12440,27 @@ The following completions are currently available:
(license license:gpl3+)))
(define-public emacs-sway
- ;; Commit from Nicola's fork (dash free version with various improvments)
- (let ((commit "838ef531a30fe616f0141adbdabc132d4edfd374")
- (revision "0"))
- (package
- (name "emacs-sway")
- (version (git-version "0.6.1" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/thblt/sway.el")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0ddaz8my3z4ca2z81kf1h8773pyx8h0l0ra3ssqd1rq5j0041wdh"))))
- (build-system emacs-build-system)
- (home-page "https://github.com/thblt/sway.el")
- (synopsis "Communication with the Sway window manager")
- (description
- "This is a basic library to control the Sway window manager from Emacs.
+ (package
+ (name "emacs-sway")
+ (version "0.7")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/thblt/sway.el")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1w29dkl7s835zgwnc4jx1cp84s6mmwbvlil8z2c31psy0rlajc6i"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/thblt/sway.el")
+ (synopsis "Communication with the Sway window manager")
+ (description
+ "This is a basic library to control the Sway window manager from Emacs.
Its main use case is in combination with popup managers like Shackle, to
use frames instead of windows while still giving focus to existing frames
instead of duplicating them.")
- (license license:gpl3+))))
+ (license license:gpl3+)))
(define-public emacs-sweet-theme
(let ((commit "78f741806ecebe01224bf54d09ad80e306652508")