aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-24 21:29:29 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-03 22:23:23 +0100
commit5ed48f9d6c857dfb8e863b18d5099d82d17d8d2d (patch)
treec00307198cc3905519a69dba98632a63ae660225
parent44ec3b17df78b62b07a55ee136ca9f6eb506ad08 (diff)
downloadguix-5ed48f9d6c857dfb8e863b18d5099d82d17d8d2d.tar
guix-5ed48f9d6c857dfb8e863b18d5099d82d17d8d2d.tar.gz
gnu: Add go-atomicgo-dev-keyboard.
* gnu/packages/golang-xyz.scm (go-atomicgo-dev-keyboard): New variable. Change-Id: I335f43f06009d188c4e3278ea00a1568a3be9235
-rw-r--r--gnu/packages/golang-xyz.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index f836449d54..7033618295 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -111,6 +111,37 @@ and games, live charts, algorithm visualizations and other updatable output of
any kind.")
(license license:expat)))
+(define-public go-atomicgo-dev-keyboard
+ (package
+ (name "go-atomicgo-dev-keyboard")
+ (version "0.2.9")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/atomicgo/keyboard")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0axhs1ji87szirv91vvwy0l0h5f468pllp8zap2dpcy05krmi9jf"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ ;; Cycle: go-github-com-pterm-pterm -> go-github-com-marvinjwendt-testza
+ ;; -> go-atomicgo-dev-keyboard -> go-github-com-pterm-pterm
+ #:tests? #f
+ #:import-path "atomicgo.dev/keyboard"))
+ (propagated-inputs
+ (list go-github-com-containerd-console))
+ (home-page "https://atomicgo.dev/keyboard")
+ (synopsis "Read keyboard events in CLI applications")
+ (description
+ "This package provides a functionality to read key presses from the keyboard,
+while in a terminal application, which may be combined to check for ctrl+c,
+alt+4, ctrl-shift, alt+ctrl+right, etc. It can also be used to
+simulate (mock) keypresses for CI testing.")
+ (license license:expat)))
+
(define-public go-atomicgo-dev-schedule
(package
(name "go-atomicgo-dev-schedule")