aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 10:10:27 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-08-14 11:00:28 +0200
commit5cfea753238fe4f6be5163f028e1bd4ed28495c4 (patch)
treeda4730344baf7a85455dd0836dd17b7a53a1030a
parentbcf729ee452db051b2c2b4ea05647458cb77f5a1 (diff)
downloadguix-5cfea753238fe4f6be5163f028e1bd4ed28495c4.tar
guix-5cfea753238fe4f6be5163f028e1bd4ed28495c4.tar.gz
gnu: Add texlive-pst-3dplot.
* gnu/packages/tex.scm (texlive-pst-3dplot): New variable.
-rw-r--r--gnu/packages/tex.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 411b0cbd12..45f2f345c5 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -32346,6 +32346,29 @@ MATLAB for plotting.")
and three dimensional representations of text or graphical objects.")
(license license:lppl)))
+(define-public texlive-pst-3dplot
+ (package
+ (name "texlive-pst-3dplot")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/generic/pst-3dplot/"
+ "dvips/pst-3dplot/"
+ "tex/generic/pst-3dplot/"
+ "tex/latex/pst-3dplot/")
+ (base32
+ "0k49c4kc126zacv2p2crdv00l50cg6kfpdnsa9m223naigifzf22")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/pst-3dplot")
+ (synopsis "Draw 3D objects in parallel projection, using PSTricks")
+ (description
+ "This package provides a package using PSTricks to draw a large variety
+of graphs and plots, including 3D maths functions. Data can be read from
+external data files, making this package a generic tool for graphing within
+TeX or LaTeX, without the need for external tools.")
+ (license license:lppl)))
+
(define-public texlive-pst-text
(package
(name "texlive-pst-text")