aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTroy Figiel <troy@troyfigiel.com>2024-01-21 18:22:09 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-02-11 21:03:06 +0000
commit579a1a8c029e97b69a7e3597ff9fd287805cf644 (patch)
tree3c1a61d9ff02f9983196a1ac0fc0cb87282c64a7
parent4bab3a26021aefd1d2b70af742d3beee2bee6e9b (diff)
downloadguix-579a1a8c029e97b69a7e3597ff9fd287805cf644.tar
guix-579a1a8c029e97b69a7e3597ff9fd287805cf644.tar.gz
gnu: Add python-pandas-vet.
* gnu/packages/python-xyz.scm (python-pandas-vet): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/python-check.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 37cabf4cff..dbc4321bb2 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -17,6 +17,7 @@
;;; Copyright © 2022 Felix Gruber <felgru@posteo.net>
;;; Copyright © 2022 Tomasz Jeneralczyk <tj@schwi.pl>
;;; Copyright © 2022 jgart <jgart@dismail.de>
+;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2338,6 +2339,31 @@ Avocado machine readable outputs this one is streamlined (per test results).
@end table")
(license license:gpl2))) ;some files are under GPLv2 only
+(define-public python-pandas-vet
+ (package
+ (name "python-pandas-vet")
+ ;; Newer versions require flake8>=6.0.0.
+ (version "0.2.3")
+ (source
+ (origin
+ ;; No tests in the PyPI tarball.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/deppen8/pandas-vet")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1b3pqcargv68p2lpv72q49siq6mxfh3znxhz9vd91rp6fd6lf2cz"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-attrs python-flake8))
+ (native-inputs (list python-pytest))
+ (home-page "https://github.com/deppen8/pandas-vet")
+ (synopsis "Opionated @code{flake8} plugin for @code{pandas} code")
+ (description
+ "This package provides a @code{flake8} plugin to lint @code{pandas} code
+in an opinionated way.")
+ (license license:expat)))
+
(define-public python-parameterizedtestcase
(package
(name "python-parameterizedtestcase")