aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2023-06-20 15:55:17 +0100
committerChristopher Baines <mail@cbaines.net>2023-06-20 22:04:51 +0100
commit53d80d04854f263e360d5f2b9e1d00ff5dad5227 (patch)
tree082f6e3a4a7a6180b88ee74e4726b9e45652ca82
parent7b535eb29b9d52221f65bd3ca9d9ae53baad0cac (diff)
downloadguix-53d80d04854f263e360d5f2b9e1d00ff5dad5227.tar
guix-53d80d04854f263e360d5f2b9e1d00ff5dad5227.tar.gz
gnu: ruby-ptools: Update to 1.5.0.
* gnu/packages/ruby.scm (ruby-ptools): Update to 1.5.0. [arguments]: Update style and adjust. [native-inputs]: Add ruby-rspec.
-rw-r--r--gnu/packages/ruby.scm38
1 files changed, 22 insertions, 16 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 3c27f1e6a1..8c0e19d015 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -3240,29 +3240,35 @@ and inspect the environment.")
(define-public ruby-ptools
(package
(name "ruby-ptools")
- (version "1.3.5")
+ (version "1.5.0")
(source (origin
(method url-fetch)
(uri (rubygems-uri "ptools" version))
(sha256
(base32
- "1jb1h1nsk9zwykpniw8filbsk26kjsdlpk5wz6w0zyamcd41h87j"))))
+ "0damllbshkxycrwjv80sz78h76dw7r9z54d17mb5cbha1daq9q2d"))))
(build-system ruby-build-system)
(arguments
- '(#:phases (modify-phases %standard-phases
- (add-after 'unpack 'patch-/bin/ls
- (lambda _
- (substitute* "test/test_binary.rb"
- (("/bin/ls")
- (which "ls")))
- #t))
- (add-before 'install 'create-gem
- (lambda _
- ;; Do not attempt to sign the gem.
- (substitute* "Rakefile"
- (("spec\\.signing_key = .*")
- ""))
- (invoke "rake" "gem:create"))))))
+ (list
+ #:test-target "spec:all"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'patch
+ (lambda _
+ (substitute* "Rakefile"
+ ;; Don't require rubocop
+ (("require 'rubocop/rake_task'") "")
+ (("RuboCop::RakeTask.new") "")
+ ;; Do not attempt to sign the gem.
+ (("spec\\.signing_key = .*") ""))
+
+ (substitute* "spec/binary_spec.rb"
+ (("/bin/ls") (which "ls"))
+ (("/bin/cat") (which "cat"))
+ (("/bin/chmod") (which "chmod"))
+ (("/bin/df") (which "df"))))))))
+ (native-inputs
+ (list ruby-rspec))
(synopsis "Extra methods for Ruby's @code{File} class")
(description
"The @dfn{ptools} (power tools) library extends Ruby's core @code{File}