aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-25 16:29:03 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-25 16:29:03 +0100
commit4f8b1fb35fd768ee937dbb6bed9f0d4e27cdf435 (patch)
treeda3331c323f967763123a9c8914cf6b1ecf79691
parent7166b77adc51072a77911e4734ccfb1ac0590485 (diff)
downloadguix-4f8b1fb35fd768ee937dbb6bed9f0d4e27cdf435.tar
guix-4f8b1fb35fd768ee937dbb6bed9f0d4e27cdf435.tar.gz
gnu: Add r-r2html.
* gnu/packages/cran.scm (r-r2html): New variable.
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 4ba686e90e..68516ecf6f 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -12845,3 +12845,29 @@ handle missing genotypes at some SNPs.")
(description
"This package provides functions for drawing and calibrating samples.")
(license license:gpl2+)))
+
+(define-public r-r2html
+ (package
+ (name "r-r2html")
+ (version "2.3.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "R2HTML" version))
+ (sha256
+ (base32
+ "00kxny7hajs9r2kw63qk7d03ggdxx2j1g8vbrmzp806y8aczvik9"))))
+ (properties `((upstream-name . "R2HTML")))
+ (build-system r-build-system)
+ (home-page "https://github.com/nalimilan/R2HTML")
+ (synopsis "HTML export for R objects")
+ (description
+ "This package includes HTML functions and methods to write in an HTML
+file. Thus, making HTML reports is easy. It includes a function that allows
+redirection on the fly, which appears to be very useful for teaching purposes,
+as the student can keep a copy of the produced output to keep all that they
+did during the course. The package comes with a vignette describing how to
+write HTML reports for statistical analysis. Finally, a driver for Sweave
+allows to parse HTML flat files containing R code and to automatically write
+the corresponding outputs (tables and graphs).")
+ (license license:gpl2+)))