aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruno Victal <mirai@makinata.eu>2023-06-22 20:33:20 +0100
committerLiliana Marie Prikler <liliana.prikler@gmail.com>2023-06-25 00:00:03 +0200
commit4346c092ea8f1c3084609d3e9173d232bf04af0c (patch)
tree59bb0ad0507d2a934c06649ef3320fb26a17f228
parent0a167432dbccb3ed5b6f27a48b61e570846cf784 (diff)
downloadguix-4346c092ea8f1c3084609d3e9173d232bf04af0c.tar
guix-4346c092ea8f1c3084609d3e9173d232bf04af0c.tar.gz
gnu: shared-mime-info: Add doc output.
* gnu/packages/freedesktop.scm (shared-mime-info[#:phases]: Add ‘install-doc’. [outputs]: Add “doc”. [native-inputs]: Add docbook-xml-4.1.2, docbook-xsl and xmlto. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
-rw-r--r--gnu/packages/freedesktop.scm17
1 files changed, 15 insertions, 2 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index b16fa5d387..65781fed11 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -545,11 +545,24 @@ display servers. It supports many different languages and emoji.")
(not (string-prefix? "./tests/mime-detection"
file))))))
(for-each patch-shebang
- (find-files "." pred #:stat lstat))))))))
+ (find-files "." pred #:stat lstat)))))
+ ;; The docs have no install rule.
+ (add-after 'install 'install-doc
+ (lambda* (#:key source #:allow-other-keys)
+ (let ((dest (string-append #$output:doc "/share/doc")))
+ (with-directory-excursion "data/shared-mime-info-spec-html"
+ (install-file "shared-mime-info-spec.html"
+ (string-append dest "/html")))
+ (install-file (string-append source
+ "/data/shared-mime-info-spec.xml")
+ dest)))))))
(inputs
(list glib libxml2))
(native-inputs
- (list gettext-minimal pkg-config python xdgmime))
+ (list gettext-minimal pkg-config python xdgmime
+ ;; For 'doc' output.
+ docbook-xml-4.1.2 docbook-xsl xmlto))
+ (outputs (list "out" "doc"))
(home-page "https://www.freedesktop.org/wiki/Software/shared-mime-info")
(synopsis "Database of common MIME types")
(description