aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDion Mendel <guix@dm9.info>2021-06-01 13:25:53 +0800
committerLudovic Courtès <ludo@gnu.org>2021-06-05 23:39:29 +0200
commit404f6145eeaf572ce824568a470eab98c124e554 (patch)
tree2f664c90a8c80f7c2e01b6e58222af4944477822
parent23ab8d417e238e735338c6bf378906ca7953f3de (diff)
downloadguix-404f6145eeaf572ce824568a470eab98c124e554.tar
guix-404f6145eeaf572ce824568a470eab98c124e554.tar.gz
gnu: Add lxcfs.
* gnu/packages/virtualization.scm (lxcfs): New Variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/virtualization.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index f12f862304..5e7dd8a10a 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -19,6 +19,7 @@
;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2021 Leo Famulari <leo@famulari.name>
;;; Copyright © 2021 Pierre Langlois <pierre.langlois@gmx.com>
+;;; Copyright © 2021 Dion Mendel <guix@dm9.info>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1065,6 +1066,35 @@ Through a powerful API and simple tools, it lets Linux users easily create and
manage system or application containers.")
(license license:lgpl2.1+)))
+(define-public lxcfs
+ (package
+ (name "lxcfs")
+ (version "4.0.8")
+ (home-page "https://github.com/lxc/lxcfs")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference (url home-page)
+ (commit (string-append "lxcfs-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1f74wy88si2ia035pcvciq5821kc8jcb75w1f8vhbp0cd29rqdpi"))))
+ (arguments
+ '(#:configure-flags '("--localstatedir=/var")))
+ (native-inputs
+ `(("autoconf" ,autoconf)
+ ("automake" ,automake)
+ ("libtool" ,libtool)
+ ("pkg-config" ,pkg-config)))
+ (inputs
+ `(("fuse" ,fuse)))
+ (build-system gnu-build-system)
+ (synopsis "FUSE based filesystem for LXC")
+ (description "LXCFS is a small FUSE filesystem written with the intention
+of making Linux containers feel more like a virtual machine.
+It started as a side-project of LXC but is useable by any runtime.")
+ (license license:lgpl2.1+)))
+
(define-public libvirt
(package
(name "libvirt")