aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-25 22:25:58 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-25 22:25:58 +0100
commit3fbccedb863fa14abfdb971fdbd63b78f4ef52ef (patch)
tree6364f6d5340d6ae9d9852d236a609433dc654d44
parentef9a6e9132859de10bc6507cf0b43b0d0cc743ac (diff)
downloadguix-3fbccedb863fa14abfdb971fdbd63b78f4ef52ef.tar
guix-3fbccedb863fa14abfdb971fdbd63b78f4ef52ef.tar.gz
gnu: go-github-com-bits-and-blooms-bloom: Update to 3.7.0.
* gnu/packages/golang.scm (go-github-com-bits-and-blooms-bloom): Update to 3.7.0. Change-Id: I7f147536c7fb075711fb50a6836554675e02a224
-rw-r--r--gnu/packages/golang.scm16
1 files changed, 3 insertions, 13 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 3acc5588a5..c4a92d7b35 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6191,7 +6191,7 @@ efficient space usage.")
(define-public go-github-com-bits-and-blooms-bloom
(package
(name "go-github-com-bits-and-blooms-bloom")
- (version "3.6.0")
+ (version "3.7.0")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -6200,20 +6200,10 @@ efficient space usage.")
(file-name (git-file-name name version))
(sha256
(base32
- "02rpjlgl7k3755qnlsk519xazgqlk73b8wvkpqlvccywms5w77bq"))))
+ "022pyzjp862ysl30aj105i2xmapn400ambjh8h1dcyjy9c0f8agn"))))
(build-system go-build-system)
(arguments
- '(#:import-path "github.com/bits-and-blooms/bloom"
- #:phases
- (modify-phases %standard-phases
- (add-after 'unpack 'patch-import-path
- (lambda _
- ;; See 'go.mod' in the source distribution of Syncthing 1.5.0 for
- ;; more information.
- ;; <https://github.com/spaolacci/murmur3/issues/29>
- (substitute* "src/github.com/bits-and-blooms/bloom/bloom.go"
- (("spaolacci") "twmb"))
- #t)))))
+ (list #:import-path "github.com/bits-and-blooms/bloom"))
(propagated-inputs
(list go-github-com-twmb-murmur3 go-github-com-bits-and-blooms-bitset))
(synopsis "Bloom filters in Go")