aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-09-13 00:35:20 +0300
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-09-16 21:43:59 +0100
commit3bcdb6a92e2ed49a4a0b290288e2bf052eddae57 (patch)
tree8c132fcbb3ef456914afd218cfc3e9c6c2b25cc9
parentee64bcfb796ef36db4b63f79540627fb25f3320a (diff)
downloadguix-3bcdb6a92e2ed49a4a0b290288e2bf052eddae57.tar
guix-3bcdb6a92e2ed49a4a0b290288e2bf052eddae57.tar.gz
gnu: Add go-github-com-jlaffaye-ftp.
* gnu/packages/golang-web.scm (go-github-com-jlaffaye-ftp): New variable. Change-Id: I51dca96f5a3f224eb96feda1196bf18d0c174633 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/golang-web.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 2ff362fd8c..aa53abdd86 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -2528,6 +2528,34 @@ Microsoft AD PAC authorization data.")
geared towards parsing MIME encoded emails.")
(license license:expat)))
+(define-public go-github-com-jlaffaye-ftp
+ (package
+ (name "go-github-com-jlaffaye-ftp")
+ (version "0.2.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jlaffaye/ftp")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0z9d1dxhx351158a22a08qbnfql7a1cajg6v3zm82m2rnp17ahir"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/jlaffaye/ftp"))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (propagated-inputs
+ (list go-github-com-hashicorp-go-multierror))
+ (home-page "https://github.com/jlaffaye/ftp")
+ (synopsis "FTP client package for Go")
+ (description
+ "Package ftp implements a @acronym{File Transfer Protocol,FTP} client as
+described in @url{https://www.rfc-editor.org/rfc/rfc959,RFC 959}.")
+ (license license:isc)))
+
(define-public go-github-com-jmespath-go-jmespath
(package
(name "go-github-com-jmespath-go-jmespath")