aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2024-08-26 10:42:51 +0200
committerGuillaume Le Vaillant <glv@posteo.net>2024-08-26 11:04:27 +0200
commit38094ff1666ecc4e264723e059771f3201235d4d (patch)
tree32d816f8aad841e352f40399ccf9e62501ada59f
parentc0a223c7c2c101e455ebae9e6868b871a7e90682 (diff)
downloadguix-38094ff1666ecc4e264723e059771f3201235d4d.tar
guix-38094ff1666ecc4e264723e059771f3201235d4d.tar.gz
gnu: cl-prevalence: Fix build with cl-usocket-0.8.8.
* gnu/packages/lisp-xyz.scm (sbcl-cl-prevalence)[arguments]: Add 'fix-build-with-usocket-bt2' phase. Change-Id: I7becd7ee92795f2aebc7d9caaf603ccb7f5f9dff
-rw-r--r--gnu/packages/lisp-xyz.scm9
1 files changed, 9 insertions, 0 deletions
diff --git a/gnu/packages/lisp-xyz.scm b/gnu/packages/lisp-xyz.scm
index 1e7825fdb7..d95655c2f8 100644
--- a/gnu/packages/lisp-xyz.scm
+++ b/gnu/packages/lisp-xyz.scm
@@ -8223,6 +8223,15 @@ compatible with ANSI-compliant Common Lisp implementations.")
(list sbcl-moptilities sbcl-s-sysdeps sbcl-s-xml))
(native-inputs
(list sbcl-fiveam sbcl-find-port))
+ (arguments
+ (list #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-build-with-usocket-bt2
+ (lambda _
+ ;; See https://github.com/40ants/cl-prevalence/pull/27
+ (substitute* "src/master-slave.lisp"
+ (("stop-process \\(bt:thread-name server-thread\\)")
+ "stop-process (bt2:thread-name server-thread)")))))))
(synopsis "Implementation of object prevalence for Common Lisp")
(description "This Common Lisp library implements object prevalence (see
@url{https://en.wikipedia.org/wiki/System_prevalence}). It allows