aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2019-03-26 13:37:07 +0100
committerPierre Neidhardt <mail@ambrevar.xyz>2019-03-26 13:44:00 +0100
commit375cb94130b222535ad7c7e0fa0d212483407351 (patch)
tree0efad5f5dee0c5386ef8fd90ca446fdf7eef05cf
parentc91ed484d0b66d5639ba01f9ba301ff762d9170d (diff)
downloadguix-375cb94130b222535ad7c7e0fa0d212483407351.tar
guix-375cb94130b222535ad7c7e0fa0d212483407351.tar.gz
gnu: wesnoth: Rename package to the-battle-for-wesnoth.
* gnu/packages/games.scm (wesnoth): Define in terms of 'deprecated-package'. (the-battle-for-wesnoth): New variable, formerly known as "wesnoth".
-rw-r--r--gnu/packages/games.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index c09b9c6812..1c89424efd 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -2108,9 +2108,9 @@ the higher you go. The game features multiplayer, unlimited FPS, smooth floor
falling, themeable graphics and sounds, and replays.")
(license license:gpl3+)))
-(define-public wesnoth
+(define-public the-battle-for-wesnoth
(package
- (name "wesnoth")
+ (name "the-battle-for-wesnoth")
(version "1.14.6")
(source (origin
(method url-fetch)
@@ -2148,6 +2148,9 @@ experience and advance levels, and are carried over from one scenario to the
next campaign.")
(license license:gpl2+)))
+(define-public wesnoth
+ (deprecated-package "wesnoth" the-battle-for-wesnoth))
+
(define-public wesnoth-server
(package
(inherit wesnoth)