aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-21 12:05:58 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-25 21:00:58 +0100
commit3750e11a8dfb0ae9f34db348e4d7cd7ce1e16e26 (patch)
tree3964e4192ce0315509f90527a131c437e0f8e0b4
parent4714623e05dd645c98554f90899d22f26f77d33d (diff)
downloadguix-3750e11a8dfb0ae9f34db348e4d7cd7ce1e16e26.tar
guix-3750e11a8dfb0ae9f34db348e4d7cd7ce1e16e26.tar.gz
gnu: go-google-golang-org-protobuf: Move to golang-build.
* gnu/packages/golang.scm (go-google-golang-org-protobuf): Move from here ... * gnu/packages/golang-build.scm: ... to here. Change-Id: Icf7676ac6288391631e83dc172a82529f1105cb2
-rw-r--r--gnu/packages/golang-build.scm51
-rw-r--r--gnu/packages/golang.scm50
2 files changed, 51 insertions, 50 deletions
diff --git a/gnu/packages/golang-build.scm b/gnu/packages/golang-build.scm
index a8f4cbeb20..f66fe16bd0 100644
--- a/gnu/packages/golang-build.scm
+++ b/gnu/packages/golang-build.scm
@@ -11,11 +11,13 @@
;;; Copyright © 2021 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
;;; Copyright © 2021 hackeryarn <artemchernyak@gmail.com>
+;;; Copyright © 2022 (unmatched-parenthesis <paren@disroot.org>
;;; Copyright © 2023 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;; Copyright © 2023 Felix Lechner <felix.lechner@lease-up.com>
;;; Copyright © 2023 Katherine Cox-Buday <cox.katherine.e@gmail.com>
;;; Copyright © 2023 Nicolas Graves <ngraves@ngraves.fr>
;;; Copyright © 2023 Timo Wilken <guix@twilken.net>
+;;; Copyright © 2024 Hilton Chain <hako@ultrarare.space>
;;; Copyright © 2024 Troy Figiel <troy@troyfigiel.com>
;;;
;;; This file is part of GNU Guix.
@@ -765,6 +767,55 @@ Go programming language.")
1.13 error values.")
(license license:bsd-3))))
+(define-public go-google-golang-org-protobuf
+ (package
+ (name "go-google-golang-org-protobuf")
+ (version "1.31.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://go.googlesource.com/protobuf")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1xf18kzz96hgfy1vlbnydrizzpxkqj2iamfdbj3dx5a1zz5mi8n0"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "google.golang.org/protobuf"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-failing-tests
+ (lambda* (#:key tests? unpack-path #:allow-other-keys)
+ (with-directory-excursion (string-append "src/" unpack-path)
+ (substitute* (find-files "." "\\_test.go$")
+ ;; XXX Failing on i686-linux:
+ ;; panic: unaligned 64-bit atomic operation
+ (("TestDynamicTypesExtensionNotFound")
+ "OffTestDynamicTypesExtensionNotFound")
+ (("TestDynamicTypesFilesChangeAfterCreation")
+ "OffTestDynamicTypesFilesChangeAfterCreation")
+ (("TestDynamicTypesFindExtensionByNameOrNumber")
+ "OffTestDynamicTypesFindExtensionByNameOrNumber")))))
+ ;; XXX: Workaround for go-build-system's lack of Go modules
+ ;; support.
+ (delete 'build)
+ (replace 'check
+ (lambda* (#:key tests? import-path #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion (string-append "src/" import-path)
+ (invoke "go" "test" "-v" "./..."))))))))
+ (propagated-inputs (list go-github-com-google-go-cmp))
+ (home-page "https://google.golang.org/protobuf")
+ (synopsis "Go library for Protocol Buffers")
+ (description
+ "The protobuf package provides a Go implementation of Protocol Buffers, a
+language and platform neutral, extensible mechanism for serializing structured
+data. It is a successor to @code{go-github-com-golang-protobuf} with an
+improved and cleaner API.")
+ (license license:bsd-3)))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 3e30cdf53f..4ca8c87cb2 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6200,56 +6200,6 @@ data serialization format.")
(home-page "https://github.com/golang/protobuf")
(license license:bsd-3)))
-(define-public go-google-golang-org-protobuf
- (package
- (name "go-google-golang-org-protobuf")
- (version "1.31.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://go.googlesource.com/protobuf")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1xf18kzz96hgfy1vlbnydrizzpxkqj2iamfdbj3dx5a1zz5mi8n0"))))
- (build-system go-build-system)
- (arguments
- (list #:import-path "google.golang.org/protobuf"
- #:phases
- #~(modify-phases %standard-phases
- (add-after 'unpack 'disable-failing-tests
- (lambda* (#:key tests? unpack-path #:allow-other-keys)
- (with-directory-excursion (string-append "src/" unpack-path)
- (substitute* (find-files "." "\\_test.go$")
- ;; XXX Failing on i686-linux:
- ;; panic: unaligned 64-bit atomic operation
- (("TestDynamicTypesExtensionNotFound")
- "OffTestDynamicTypesExtensionNotFound")
- (("TestDynamicTypesFilesChangeAfterCreation")
- "OffTestDynamicTypesFilesChangeAfterCreation")
- (("TestDynamicTypesFindExtensionByNameOrNumber")
- "OffTestDynamicTypesFindExtensionByNameOrNumber")))))
- ;; XXX: Workaround for go-build-system's lack of Go modules
- ;; support.
- (delete 'build)
- (replace 'check
- (lambda* (#:key tests? import-path #:allow-other-keys)
- (when tests?
- (with-directory-excursion (string-append "src/" import-path)
- (invoke "go" "test" "-v" "./..."))))))))
- (propagated-inputs (list go-github-com-google-go-cmp))
- (home-page "https://google.golang.org/protobuf")
- (synopsis "Go library for Protocol Buffers")
- (description
- "The protobuf package provides a Go implementation of Protocol Buffers, a
-language and platform neutral, extensible mechanism for serializing structured
-data.
-
-This package is a successor to @code{go-github-com-golang-protobuf} with an
-improved and cleaner API.")
- (license license:bsd-3)))
-
(define-public go-github-com-macronut-go-tproxy
(package
(name "go-github-com-macronut-go-tproxy")