aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Darrington <jmd@gnu.org>2014-10-20 21:37:16 +0200
committerJohn Darrington <jmd@gnu.org>2014-10-26 08:50:58 +0100
commit3435266298ae720d097d767f6be6050097a353db (patch)
treeb0cfa15e66c418ceb86a575ae029804b0cac0820
parent1d1efa6c6a4911ac20e1e3c4fdf0ecb2afb6f54a (diff)
downloadguix-3435266298ae720d097d767f6be6050097a353db.tar
guix-3435266298ae720d097d767f6be6050097a353db.tar.gz
gnu: Add cppunit
* gnu/packages/check.scm (cppunit): New variable.
-rw-r--r--gnu/packages/check.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index ebb04e2b53..3d33fae78d 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -46,3 +46,26 @@ catch both assertion failures and code errors that cause segmentation
faults or other signals. The output from unit tests can be used within
source code editors and IDEs.")
(license lgpl2.1+)))
+
+
+(define-public cppunit
+ (package
+ (name "cppunit")
+ (version "1.12.1")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/cppunit/" name "/"
+ name "-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0jm49v5rmc5qw34vqs56gy8xja1dhci73bmh23cig4kcir6a0a5c"))))
+ (build-system gnu-build-system)
+ (home-page "http://sourceforge.net/projects/cppunit/")
+ (synopsis "Unit testing framework for C++")
+ (description "CppUnit is the C++ port of the famous JUnit framework for
+unit testing. Test output is in XML for automatic testing and GUI based for
+supervised tests.")
+ (license lgpl2.1))) ; no copyright notices. LGPL2.1 is in the tarball
+
+