aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-11-20 22:52:52 +0000
committerEric Bavier <bavier@posteo.net>2023-12-04 14:49:33 -0600
commit33f9d3cc36fbfbd2849d626492721667abfe8306 (patch)
tree291261a7015682a0d7e2976f13e4b4f0609582fd
parent597f1cd1c46ffb92c3e0145de0071545a4c64865 (diff)
downloadguix-33f9d3cc36fbfbd2849d626492721667abfe8306.tar
guix-33f9d3cc36fbfbd2849d626492721667abfe8306.tar.gz
gnu: python-cdflib: Disable shaky test.
* gnu/packages/astronomy.scm (python-cdflib): Disable one test which causes random build failure. [arguments]{test-flags}: Add it. Change-Id: I05ee2feca3bc0f0139fa1a5f00b4fe260b42ec80 Signed-off-by: Eric Bavier <bavier@posteo.net>
-rw-r--r--gnu/packages/astronomy.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index c063285b52..da15283ef3 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -1807,7 +1807,10 @@ bad pixel tracking throughout the reduction process.")
(base32 "0vpgcbc9pmx0qqfia1frnwq3jkgfp8y3ikqdnzs5bs1sr13p9p3w"))))
(build-system pyproject-build-system)
(arguments
- (list #:phases
+ ;; Disable shaky test.
+ ;; See https://github.com/MAVENSDC/cdflib/issues/234
+ (list #:test-flags #~(list "-k" "not test_compute_cdfepoch16")
+ #:phases
#~(modify-phases %standard-phases
(add-before 'build 'set-env-version
(lambda _