aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-13 22:20:55 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-15 12:17:53 +0100
commit33edddb2cacec8cbbd3507d8a77c64d64f73e935 (patch)
tree57e361331c14393ce0d97140b727cb0e47489dcb
parent07dbf74fb83c17cb9851ff4fa2f3435feaab1083 (diff)
downloadguix-33edddb2cacec8cbbd3507d8a77c64d64f73e935.tar
guix-33edddb2cacec8cbbd3507d8a77c64d64f73e935.tar.gz
gnu: govulncheck: Adjust package style.
* gnu/packages/golang.scm (govulncheck): Adjust indentation and swap inputs to propagated-inputs. [inputs]: Remove go-golang-org-x-sys, go-github-com-google-renameio, go-github-com-burntsushi-toml, go-mvdan-cc-unparam, go-honnef-co-go-tools, go-golang-org-x-tools, go-golang-org-x-sync, go-golang-org-x-mod, go-golang-org-x-exp, go-github-com-google-go-cmp-cmp, go-github-com-google-go-cmdtest, and go-github-com-client9-misspell. [propagated-inputs]: Add go-github-com-google-go-cmdtest, go-github-com-google-go-cmp-cmp, go-golang-org-x-mod, go-golang-org-x-exp go-golang-org-x-sync, and go-golang-org-x-tools. Change-Id: I1155d11eed11aff248cf1c1356048ccffcf57a64
-rw-r--r--gnu/packages/golang.scm49
1 files changed, 23 insertions, 26 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index dd629ad29c..74ffad3be2 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3160,34 +3160,31 @@ command-line parsers.")
;; XXX: Newer version of govulncheck requires golang.org/x/telemetry,
;; which needs to be discussed if it may be included in Guix.
(version "0.0.0-20230110180137-6ad3e3d07815")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://go.googlesource.com/vuln")
- (commit (go-version->git-ref version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "1fhz27ni8bs872rgvqq700qacak9v45zy0fh2hilq21sk6dks72r"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://go.googlesource.com/vuln")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1fhz27ni8bs872rgvqq700qacak9v45zy0fh2hilq21sk6dks72r"))))
(build-system go-build-system)
(arguments
- `(#:tests? #f ; it tires to download modules from the network
- #:install-source? #f
- #:import-path "golang.org/x/vuln/cmd/govulncheck"
- #:unpack-path "golang.org/x/vuln"))
- (native-inputs (list coreutils-minimal))
- (inputs (list go-golang-org-x-sys
- go-github-com-google-renameio
- go-github-com-burntsushi-toml
- go-mvdan-cc-unparam
- go-honnef-co-go-tools
- go-golang-org-x-tools
- go-golang-org-x-sync
- go-golang-org-x-mod
- go-golang-org-x-exp
- go-github-com-google-go-cmp-cmp
- go-github-com-google-go-cmdtest
- go-github-com-client9-misspell))
+ (list
+ #:tests? #f ; it tires to download modules from the network
+ #:install-source? #f
+ #:import-path "golang.org/x/vuln/cmd/govulncheck"
+ #:unpack-path "golang.org/x/vuln"))
+ (native-inputs
+ (list coreutils-minimal))
+ (propagated-inputs
+ (list go-github-com-google-go-cmdtest
+ go-github-com-google-go-cmp-cmp
+ go-golang-org-x-exp
+ go-golang-org-x-mod
+ go-golang-org-x-sync
+ go-golang-org-x-tools))
(home-page "https://golang.org/x/vuln")
(synopsis "Go Vulnerability Management")
(description