aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-05-30 20:58:37 +0100
committerEfraim Flashner <efraim@flashner.co.il>2023-06-14 14:52:22 +0300
commit308bee5f000703f063f5fbccd1c439e8c905a09c (patch)
tree1983217669f9cc0577ac76fe1f620ca9677db1c7
parent95c1e5121a1238c745860d7a7033bdb30c91b7cf (diff)
downloadguix-308bee5f000703f063f5fbccd1c439e8c905a09c.tar
guix-308bee5f000703f063f5fbccd1c439e8c905a09c.tar.gz
gnu: Add python-tweakwcs.
* gnu/packages/astronomy.scm (python-tweakwcs): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
-rw-r--r--gnu/packages/astronomy.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 2f708ff652..c411af0e54 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2832,6 +2832,40 @@ Takes a WGS84 (GPS) latitude/longitude as input as well as an UTC or local
datetime object.")
(license license:lgpl3+)))
+(define-public python-tweakwcs
+ (package
+ (name "python-tweakwcs")
+ (version "0.8.2")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "tweakwcs" version))
+ (sha256
+ (base32
+ "1500w737n9vf5hv16xkybk4shl7g4wfzb2ji9mc4vgzj41gkrwl4"))))
+ (build-system pyproject-build-system)
+ (propagated-inputs (list python-astropy
+ python-gwcs
+ python-numpy
+ python-packaging
+ python-spherical-geometry
+ python-stsci-imagestats
+ python-stsci-stimage))
+ (native-inputs (list python-codecov
+ python-pytest
+ python-pytest-cov
+ python-scipy
+ python-semantic-version
+ python-setuptools-scm))
+ (home-page "https://tweakwcs.readthedocs.io/en/latest/")
+ (synopsis
+ "Algorithms for matching and aligning catalogs and for tweaking the WCS")
+ (description
+ "@code{tweakwcs} is a package that provides core algorithms for computing
+and applying corrections to @code{WCS} objects such as to minimize mismatch
+between image and reference catalogs. Currently only aligning images with
+@code{FITS WCS} and @code{JWST gWCS} are supported.")
+ (license license:bsd-3)))
+
(define-public python-asdf
(package
(name "python-asdf")