aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNikolai Merinov <nikolai.merinov@member.fsf.org>2018-10-16 02:37:41 +0500
committerDanny Milosavljevic <dannym@scratchpost.org>2018-10-26 18:11:15 +0200
commit2e2b8635b99167554bc51a9d1067c808bcb63d37 (patch)
treec965b89e4d35c51a9dc7a810263f4dd60000df52
parente027a494fd5e6025e645ce9f36cccca39a77d327 (diff)
downloadguix-2e2b8635b99167554bc51a9d1067c808bcb63d37.tar
guix-2e2b8635b99167554bc51a9d1067c808bcb63d37.tar.gz
gnu: rust: Update to 1.28.
* gnu/packages/rust.scm (rust): Rename to... (rust-1.27): ... this. (rust): New variable.
-rw-r--r--gnu/packages/rust.scm36
1 files changed, 35 insertions, 1 deletions
diff --git a/gnu/packages/rust.scm b/gnu/packages/rust.scm
index 9a7d207dcf..cd4656ea03 100644
--- a/gnu/packages/rust.scm
+++ b/gnu/packages/rust.scm
@@ -776,7 +776,7 @@ jemalloc = \"" jemalloc "/lib/libjemalloc_pic.a" "\"
(("fn no_index_update") "#[ignore]\nfn no_index_update"))
#t)))))))))
-(define-public rust
+(define-public rust-1.27
(let ((base-rust
(rust-bootstrapped-package rust-1.26 "1.27.2"
"0pg1s37bhx9zqbynxyydq5j6q7kij9vxkcv8maz0m25prm88r0cs"
@@ -804,3 +804,37 @@ jemalloc = \"" jemalloc "/lib/libjemalloc_pic.a" "\"
(substitute* "src/tools/cargo/tests/testsuite/path.rs"
(("fn thin_lto_works") "#[ignore]\nfn thin_lto_works"))
#t)))))))))
+
+(define-public rust
+ (let ((base-rust
+ (rust-bootstrapped-package rust-1.27 "1.28.0"
+ "11k4rn77bca2rikykkk9fmprrgjswd4x4kaq7fia08vgkir82nhx"
+ #:patches
+ '("rust-coresimd-doctest.patch"
+ "rust-bootstrap-stage0-test.patch"
+ "rust-1.25-accept-more-detailed-gdb-lines.patch"
+ "rust-mdbook-support-reproducible-builds-by-forcing-window.search.patch"))))
+ (package
+ (inherit base-rust)
+ (inputs
+ ;; Use LLVM 6.0
+ (alist-replace "llvm" (list llvm)
+ (package-inputs base-rust)))
+ (arguments
+ (substitute-keyword-arguments (package-arguments base-rust)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-after 'configure 'enable-codegen-tests
+ ;; Codegen tests should pass with llvm 6, so enable them.
+ (lambda* _
+ (substitute* "config.toml"
+ (("codegen-tests = false") ""))
+ #t))
+ (add-after 'patch-tests 'disable-amd64-avx-test
+ ;; That test would fail on x86_64 machines without avx.
+ (lambda* _
+ (substitute* "src/test/run-pass/issue-44056.rs"
+ (("only-x86_64") "ignore-test"))
+ #t))
+ ;; The thinlto test should pass with llvm 6.
+ (delete 'disable-thinlto-test))))))))