aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Kehayias <john.kehayias@protonmail.com>2024-09-12 15:02:49 -0400
committerJohn Kehayias <john.kehayias@protonmail.com>2024-09-15 20:38:54 -0400
commit2db055a4e56eab134852a16a24443148dc32b5a2 (patch)
treef850123e1cc703b33103f5c973efe0d74142dc30
parent83698b6fa037aa1f3adc38f474be41bac7622ed8 (diff)
downloadguix-2db055a4e56eab134852a16a24443148dc32b5a2.tar
guix-2db055a4e56eab134852a16a24443148dc32b5a2.tar.gz
gnu: Add cmake-3.30.
Add newer version of cmake for packages that will need it (for instance, new features like finding EGL2), without yet updating the default and rebuilding all cmake packages. * gnu/packages/cmake.scm (cmake-3.30): New variable. Change-Id: I345e9cab7a79624ff0012f493c18426bd843e0d6
-rw-r--r--gnu/packages/cmake.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index 0c780fe420..ac75321937 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -12,6 +12,7 @@
;;; Copyright © 2019 Pierre-Moana Levesque <pierre.moana.levesque@gmail.com>
;;; Copyright © 2020, 2023 Janneke Nieuwenhuizen <janneke@gnu.org>
;;; Copyright © 2021 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2024 John Kehayias <john.kehayias@protonmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -409,6 +410,26 @@ and workspaces that can be used in the compiler environment of your choice.")
texinfo)))
(properties (alist-delete 'hidden? (package-properties cmake-minimal)))))
+(define-public cmake-3.30
+ (package
+ (inherit cmake)
+ (version "3.30.3")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://cmake.org/files/v"
+ (version-major+minor version)
+ "/cmake-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1r48zym4dy4mvwzk704zh1vx9gb4a910f424ypvis28mcxdy2pbd"))))
+ (native-inputs
+ (modify-inputs (package-native-inputs cmake)
+ ;; Avoid circular dependency with (gnu packages debug). Note: cppdap
+ ;; is built with cmake, so when the default cmake is updated to this
+ ;; version this circular dependency will need to be worked around.
+ (prepend (module-ref (resolve-interface '(gnu packages debug))
+ 'cppdap))))))
+
(define-public cmake-minimal-cross
(package
(inherit cmake-minimal)