aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 16:22:26 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-30 19:41:44 +0200
commit2b377b5b8a1a300b83c0b92eb40e3b9a25203788 (patch)
tree1680fc0b4cfc91256fc0b6836f144906f8d25fd0
parentb880116b3bb4df72bf26b9c6774539422a2784d8 (diff)
downloadguix-2b377b5b8a1a300b83c0b92eb40e3b9a25203788.tar
guix-2b377b5b8a1a300b83c0b92eb40e3b9a25203788.tar.gz
gnu: Add texlive-hepnames.
* gnu/packages/tex.scm (texlive-hepnames): New variable.
-rw-r--r--gnu/packages/tex.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 01ffcd2c68..0bb94ad71a 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -3962,6 +3962,31 @@ macros to improve the default behavior of LaTeX for High Energy Physics
publications.")
(license license:lppl1.3c)))
+(define-public texlive-hepnames
+ (package
+ (name "texlive-hepnames")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/hepnames/" "tex/latex/hepnames/")
+ (base32
+ "1wvqf4r7p8bkvxwp7mvqnngxillbpii38i413q8acz0777bpassl")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/hepnames")
+ (synopsis "Pre-defined high energy particle names")
+ (description
+ "Hepnames provides a pair of LaTeX packages, @code{heppennames} and @code{hepnicenames},
+providing a large set of pre-defined high energy physics particle names built
+with the @code{hepparticles} package. The packages are based on
+@file{pennames.sty} by Michel Goosens and Eric van Herwijnen. Heppennames
+re-implements the particle names in @file{pennames.sty}, with some additions
+and alterations and greater flexibility and robustness due to the
+@code{hepparticles} structures, which were written for this purpose.
+Hepnicenames provides the main non-resonant particle names from
+@code{heppennames} with more friendly names.")
+ (license license:lppl)))
+
(define-public texlive-bibtex8
(package
(name "texlive-bibtex8")