aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-09-27 15:37:54 +0300
committerEfraim Flashner <efraim@flashner.co.il>2023-09-28 13:48:31 +0300
commit2b1ae1cffc6a94935c2501c393ee210c2cf68c16 (patch)
treed1e6023044d83492ba74d195db09cf243256aec3
parent6fa85076aefe93448bd3c57e841aa1d727b09415 (diff)
downloadguix-2b1ae1cffc6a94935c2501c393ee210c2cf68c16.tar
guix-2b1ae1cffc6a94935c2501c393ee210c2cf68c16.tar.gz
gnu: emacs-elfeed: Patch curl executable.
Reported by bienjensu on IRC. * gnu/packages/emacs-xyz.scm (emacs-elfeed)[arguments]: Add a phase to patch a call to the curl binary. [inputs]: Add curl.
-rw-r--r--gnu/packages/emacs-xyz.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index d19f8e9f81..1f2334e409 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -13856,7 +13856,16 @@ and tooling.")
(build-system emacs-build-system)
(arguments
`(#:tests? #t
- #:test-command '("make" "test")))
+ #:test-command '("make" "test")
+ #:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'patch-program-calls
+ (lambda* (#:key inputs #:allow-other-keys)
+ (emacs-substitute-variables "elfeed-curl.el"
+ ("elfeed-curl-program-name"
+ (search-input-file inputs "/bin/curl"))))))))
+ (inputs
+ (list curl))
(home-page "https://github.com/skeeto/elfeed")
(synopsis "Atom/RSS feed reader for Emacs")
(description