aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2023-11-29 22:34:50 +0000
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-01-03 16:35:15 -0500
commit2a0b7df5b4b9e7b27a79e7ecc646113af97808b1 (patch)
tree4adb552da685a6d0b40ec984f045f349f4ce49e7
parent170d43cd0d954f09480ed71b29a981ac2a179065 (diff)
downloadguix-2a0b7df5b4b9e7b27a79e7ecc646113af97808b1.tar
guix-2a0b7df5b4b9e7b27a79e7ecc646113af97808b1.tar.gz
gnu: go-github-com-felixge-httpsnoop: Move to (gnu packages golang-web).
* gnu/packages/golang.scm (go-github-com-felixge-httpsnoop): Move from here... * gnu/packages/golang-web.scm: ...to here. Change-Id: Ic2494b3e45c934ecddaa621f00f474b9079dc5ed
-rw-r--r--gnu/packages/golang-web.scm24
-rw-r--r--gnu/packages/golang.scm25
2 files changed, 24 insertions, 25 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index 3a3c5f9621..c0ceb5b7ce 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -118,6 +118,30 @@ the parse trees produced by the html package.")
(description "This package provides a CSS parser and inliner.")
(license license:expat)))
+(define-public go-github-com-felixge-httpsnoop
+ (package
+ (name "go-github-com-felixge-httpsnoop")
+ (version "1.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/felixge/httpsnoop")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0ncd8lar5zxiwjhsp315s4hsl4bhnm271h49jhyxc66r5yffgmac"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/felixge/httpsnoop"))
+ (home-page "https://github.com/felixge/httpsnoop/")
+ (synopsis "Capture http related metrics")
+ (description
+ "Httpsnoop provides an easy way to capture http related
+metrics (i.e. response time, bytes written, and http status code) from your
+application's http.Handlers.")
+ (license license:expat)))
+
(define-public go-github-com-gorilla-css
(package
(name "go-github-com-gorilla-css")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index fb826c2743..841b507cda 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -5145,31 +5145,6 @@ GNU extensions} to the POSIX recommendations for command-line options.")
all types of configuration needs and formats.")
(license license:expat)))
-(define-public go-github-com-felixge-httpsnoop
- (package
- (name "go-github-com-felixge-httpsnoop")
- (version "1.0.1")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/felixge/httpsnoop")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "0ncd8lar5zxiwjhsp315s4hsl4bhnm271h49jhyxc66r5yffgmac"))))
- (build-system go-build-system)
- (arguments
- '(#:import-path "github.com/felixge/httpsnoop"))
- (home-page "https://github.com/felixge/httpsnoop/")
- (synopsis "Capture http related metrics")
- (description
- "Httpsnoop provides an easy way to capture http related
-metrics (i.e. response time, bytes written, and http status code) from your
-application's http.Handlers.")
- (license license:expat)))
-
(define-public go-github-com-fsnotify-fsnotify
(package
(name "go-github-com-fsnotify-fsnotify")