aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2023-12-13 22:56:26 +0100
committerRicardo Wurmus <rekado@elephly.net>2024-04-22 11:29:30 +0200
commit2528aabf6f1fa5d1fcf9d58afa2a67cf4fd91896 (patch)
treec6ececb5d45d7b573a7c99cce53dda47cc4dab6a
parent1039ec03bec357d6b3a74d4743a99acc77328f14 (diff)
downloadguix-2528aabf6f1fa5d1fcf9d58afa2a67cf4fd91896.tar
guix-2528aabf6f1fa5d1fcf9d58afa2a67cf4fd91896.tar.gz
gnu: python-jinja2: Update to 3.1.2.
* gnu/packages/python-xyz.scm (python-jinja2): Update to 3.1.2. Format. [build-system]: Use pyproject-build-system. [arguments]: Remove uneeded argument.
-rw-r--r--gnu/packages/python-xyz.scm16
1 files changed, 3 insertions, 13 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c7a56d7acf..beea08ba64 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -6095,26 +6095,17 @@ possible.")
for Python.")
(license license:bsd-3)))
-
(define-public python-jinja2
(package
(name "python-jinja2")
- (version "3.1.1")
+ (version "3.1.2")
(source
(origin
(method url-fetch)
(uri (pypi-uri "Jinja2" version))
(sha256
- (base32
- "1saawzys14l1p4kafs7hkihmnvqjq8fwxjmkjiqx3jq1nm5ys2v4"))))
- (build-system python-build-system)
- (arguments
- '(#:phases (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (if tests?
- (invoke "pytest" "-vv")
- (format #t "test suite not run~%")))))))
+ (base32 "0lp86yadzf8dph67f6g3yxmvnhrzzi863z58jmsrx2j059q1ld9i"))))
+ (build-system pyproject-build-system)
(native-inputs (list python-pytest))
(propagated-inputs (list python-markupsafe))
(home-page "https://jinja.palletsprojects.com/")
@@ -6124,7 +6115,6 @@ for Python.")
written in pure Python.")
(license license:bsd-3)))
-
(define-public python-jinja2-time
(package
(name "python-jinja2-time")