aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSimon Tournier <zimon.toutoune@gmail.com>2023-05-09 19:04:04 +0200
committerJohn Kehayias <john.kehayias@protonmail.com>2024-04-16 21:06:54 -0400
commit24b82ad3aa6554d03b4165243905753133c7804c (patch)
tree279da95fe491175f4b5d9480e6bc11e3588f647f
parent2d5736cc3e869fadd2592cc13a8d332fac63b144 (diff)
downloadguix-24b82ad3aa6554d03b4165243905753133c7804c.tar
guix-24b82ad3aa6554d03b4165243905753133c7804c.tar.gz
gnu: gcc-toolchain: Do not use gcc-final.
* gnu/packages/commencement.scm (gcc-toolchain): Bind to the default gcc-toolchain-11 being consitent with others. (gcc-toolchain-11): Make it from gcc-11. (gcc-toolchain-aka-gcc): Bind to gcc-toolchain.
-rw-r--r--gnu/packages/commencement.scm10
1 files changed, 6 insertions, 4 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 9124f0e2e0..390bdad250 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -3616,8 +3616,6 @@ is the GNU Compiler Collection.")
("libc-debug" ,libc "debug")
("libc-static" ,libc "static"))))))
-(define-public gcc-toolchain
- (make-gcc-toolchain gcc-final))
(define-public gcc-toolchain-4.8
(make-gcc-toolchain gcc-4.8))
@@ -3644,7 +3642,7 @@ is the GNU Compiler Collection.")
(make-gcc-toolchain gcc-10))
(define-public gcc-toolchain-11
- gcc-toolchain)
+ (make-gcc-toolchain gcc-11))
(define-public gcc-toolchain-12
(make-gcc-toolchain gcc-12))
@@ -3652,10 +3650,14 @@ is the GNU Compiler Collection.")
(define-public gcc-toolchain-13
(make-gcc-toolchain gcc-13))
+;; The default GCC
+(define-public gcc-toolchain
+ gcc-toolchain-11)
+
(define-public gcc-toolchain-aka-gcc
;; It's natural for users to try "guix install gcc". This package
;; automatically "redirects" them to 'gcc-toolchain'.
- (deprecated-package "gcc" gcc-toolchain-11))
+ (deprecated-package "gcc" gcc-toolchain))
(define-public gdc-toolchain-10