aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2024-06-18 21:09:43 -0400
committerLeo Famulari <leo@famulari.name>2024-07-03 21:47:19 -0400
commit190ca32d243fc8a0341cb8d90ae2485a6e646bb3 (patch)
tree48ccdb12e9b018f3ab160a0d0dd8b1f2df98c1bc
parent66e9ce2bae16990e3ce4edad2fd17e767634a16b (diff)
downloadguix-190ca32d243fc8a0341cb8d90ae2485a6e646bb3.tar
guix-190ca32d243fc8a0341cb8d90ae2485a6e646bb3.tar.gz
gnu: Add python-requests 2.31.0.
This is the minimum required version in recent versions of yt-dlp. * gnu/packages/python-web.scm (python-requests-next): New variable. Change-Id: I825cb928297cddc2fbbca1ce5acdbf6cff276bbc
-rw-r--r--gnu/packages/python-web.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 1363e6ccdf..2686cb283f 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -3603,6 +3603,32 @@ APIs.")
than Python’s urllib2 library.")
(license license:asl2.0)))
+(define-public python-requests-next
+ (package
+ (name "python-requests")
+ (version "2.31.0")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "requests" version))
+ (sha256
+ (base32
+ "1qfidaynsrci4wymrw3srz8v1zy7xxpcna8sxpm91mwqixsmlb4l"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ (list python-certifi
+ python-charset-normalizer
+ python-idna
+ python-urllib3))
+ (arguments
+ ;; FIXME: Some tests require network access.
+ '(#:tests? #f))
+ (home-page "http://python-requests.org/")
+ (synopsis "Python HTTP library")
+ (description
+ "Requests is a Python HTTP client library. It aims to be easier to use
+than Python’s urllib2 library.")
+ (license license:asl2.0)))
+
(define-public python-requests-kerberos
(package
(name "python-requests-kerberos")