aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMathieu Lirzin <mthl@openmailbox.org>2015-09-13 22:26:37 +0200
committerMathieu Lirzin <mthl@openmailbox.org>2015-09-14 23:10:58 +0200
commit17d8e33f316b7e88aa06452f873b59770989f1b6 (patch)
treef2b9581ba113a5dc45d6c722534c3ee9deca0176
parent9c38b54027ee009f9ff604342ae99c4ebd7958a6 (diff)
downloadguix-17d8e33f316b7e88aa06452f873b59770989f1b6.tar
guix-17d8e33f316b7e88aa06452f873b59770989f1b6.tar.gz
doc: Use the recommended Scheme format.
Apply the recommended formatting rules from '.dir-locals.el' to the examples in the manual in order to fulfill it's purpose of being a reference. * doc/package-hello.scm: Indent it. * doc/guix.texi (Defining Packages, Version Numbers): Likewise. * gnu/packages/base.scm (hello): Be consistent with the manual.
-rw-r--r--doc/guix.texi31
-rw-r--r--doc/package-hello.scm5
-rw-r--r--gnu/packages/base.scm29
3 files changed, 34 insertions, 31 deletions
diff --git a/doc/guix.texi b/doc/guix.texi
index ff3a9c47b7..51f7cb24b9 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -1963,13 +1963,14 @@ package looks like this:
(define-public hello
(package
(name "hello")
- (version "2.8")
+ (version "2.10")
(source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/hello/hello-" version
- ".tar.gz"))
- (sha256
- (base32 "0wqd8sjmxfskrflaxywc7gqw7sfawrfvdxd9skxawzfgyy0pzdz6"))))
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/hello/hello-" version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0ssi1wpaf7plaswqqjwigppsg5fyh99vdlb9kzl7c9lng89ndq1i"))))
(build-system gnu-build-system)
(arguments `(#:configure-flags '("--enable-silent-rules")))
(inputs `(("gawk" ,gawk)))
@@ -7232,22 +7233,22 @@ For instance, the versions 2.24.20 and 3.9.12 of GTK+ may be packaged as follows
@example
(define-public gtk+
(package
- (name "gtk+")
- (version "3.9.12")
- ...))
+ (name "gtk+")
+ (version "3.9.12")
+ ...))
(define-public gtk+-2
(package
- (name "gtk+")
- (version "2.24.20")
- ...))
+ (name "gtk+")
+ (version "2.24.20")
+ ...))
@end example
If we also wanted GTK+ 3.8.2, this would be packaged as
@example
(define-public gtk+-3.8
(package
- (name "gtk+")
- (version "3.8.2")
- ...))
+ (name "gtk+")
+ (version "3.8.2")
+ ...))
@end example
diff --git a/doc/package-hello.scm b/doc/package-hello.scm
index b3fcd4ff73..c57eb89108 100644
--- a/doc/package-hello.scm
+++ b/doc/package-hello.scm
@@ -4,13 +4,14 @@
(package
(name "hello")
- (version "2.8")
+ (version "2.10")
(source (origin
(method url-fetch)
(uri (string-append "mirror://gnu/hello/hello-" version
".tar.gz"))
(sha256
- (base32 "0wqd8sjmxfskrflaxywc7gqw7sfawrfvdxd9skxawzfgyy0pzdz6"))))
+ (base32
+ "0ssi1wpaf7plaswqqjwigppsg5fyh99vdlb9kzl7c9lng89ndq1i"))))
(build-system gnu-build-system)
(synopsis "Hello, GNU world: An example GNU package")
(description "Guess what GNU Hello prints!")
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index f35f619201..c5f447736a 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -49,22 +49,23 @@
(define-public hello
(package
- (name "hello")
- (version "2.10")
- (source (origin
- (method url-fetch)
- (uri (string-append "mirror://gnu/hello/hello-" version
- ".tar.gz"))
- (sha256
- (base32 "0ssi1wpaf7plaswqqjwigppsg5fyh99vdlb9kzl7c9lng89ndq1i"))))
- (build-system gnu-build-system)
- (synopsis "Hello, GNU world: An example GNU package")
- (description
- "GNU Hello prints the message \"Hello, world!\" and then exits. It
+ (name "hello")
+ (version "2.10")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/hello/hello-" version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0ssi1wpaf7plaswqqjwigppsg5fyh99vdlb9kzl7c9lng89ndq1i"))))
+ (build-system gnu-build-system)
+ (synopsis "Hello, GNU world: An example GNU package")
+ (description
+ "GNU Hello prints the message \"Hello, world!\" and then exits. It
serves as an example of standard GNU coding practices. As such, it supports
command-line arguments, multiple languages, and so on.")
- (home-page "http://www.gnu.org/software/hello/")
- (license gpl3+)))
+ (home-page "http://www.gnu.org/software/hello/")
+ (license gpl3+)))
(define-public grep
(package