aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2016-06-21 12:25:56 +0200
committerLudovic Courtès <ludo@gnu.org>2016-06-21 12:25:56 +0200
commit15a3fffc593a2385bbac60913909833babc1625f (patch)
tree382a6fcdbe5e52aedb5d65effcec9e24fb7b409f
parent8472bdecb634e2f3015a61e16c59b62831b82ea9 (diff)
downloadguix-15a3fffc593a2385bbac60913909833babc1625f.tar
guix-15a3fffc593a2385bbac60913909833babc1625f.tar.gz
gnu: yasm: Move to (gnu packages assembly).
* gnu/packages/yasm.scm: Remove. Move 'yasm' to... * gnu/packages/assembly.scm (yasm): ... here. New variable. * gnu/local.mk (GNU_SYSTEM_MODULES): Adjust accordingly.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/assembly.scm34
-rw-r--r--gnu/packages/yasm.scm55
3 files changed, 33 insertions, 57 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 4941414841..eb0ea41ca4 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -364,7 +364,6 @@ GNU_SYSTEM_MODULES = \
%D%/packages/xdisorg.scm \
%D%/packages/xorg.scm \
%D%/packages/xfce.scm \
- %D%/packages/yasm.scm \
%D%/packages/yubico.scm \
%D%/packages/zile.scm \
%D%/packages/zip.scm \
diff --git a/gnu/packages/assembly.scm b/gnu/packages/assembly.scm
index 0c0b1da344..575856a13e 100644
--- a/gnu/packages/assembly.scm
+++ b/gnu/packages/assembly.scm
@@ -1,5 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
+;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -23,7 +25,9 @@
#:use-module (guix packages)
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages perl)
- #:use-module (gnu packages texinfo))
+ #:use-module (gnu packages texinfo)
+ #:use-module (gnu packages python)
+ #:use-module (gnu packages xml))
(define-public nasm
(package
@@ -59,3 +63,31 @@ complex. It supports all currently known x86 architectural extensions, and
has strong support for macros.")
(supported-systems '("x86_64-linux" "i686-linux"))
(license license:bsd-3)))
+
+(define-public yasm
+ (package
+ (name "yasm")
+ (version "1.3.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://www.tortall.net/projects/yasm/releases/yasm-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "0gv0slmm0qpq91za3v2v9glff3il594x5xsrbgab7xcmnh0ndkix"))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("python" ,python-wrapper)
+ ("xmlto" ,xmlto)))
+ (home-page "http://yasm.tortall.net/")
+ (synopsis "Rewrite of the NASM assembler")
+ (description
+ "Yasm is a complete rewrite of the NASM assembler.
+
+Yasm currently supports the x86 and AMD64 instruction sets, accepts NASM
+and GAS assembler syntaxes, outputs binary, ELF32, ELF64, 32 and 64-bit
+Mach-O, RDOFF2, COFF, Win32, and Win64 object formats, and generates source
+debugging information in STABS, DWARF 2, and CodeView 8 formats.")
+ (license (license:non-copyleft "file://COPYING"
+ "See COPYING in the distribution."))))
diff --git a/gnu/packages/yasm.scm b/gnu/packages/yasm.scm
deleted file mode 100644
index 31a9083cdf..0000000000
--- a/gnu/packages/yasm.scm
+++ /dev/null
@@ -1,55 +0,0 @@
-;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
-;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
-;;;
-;;; This file is part of GNU Guix.
-;;;
-;;; GNU Guix is free software; you can redistribute it and/or modify it
-;;; under the terms of the GNU General Public License as published by
-;;; the Free Software Foundation; either version 3 of the License, or (at
-;;; your option) any later version.
-;;;
-;;; GNU Guix is distributed in the hope that it will be useful, but
-;;; WITHOUT ANY WARRANTY; without even the implied warranty of
-;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
-;;; GNU General Public License for more details.
-;;;
-;;; You should have received a copy of the GNU General Public License
-;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
-
-(define-module (gnu packages yasm)
- #:use-module (gnu packages)
- #:use-module ((guix licenses) #:prefix license:)
- #:use-module (guix packages)
- #:use-module (guix download)
- #:use-module (guix build-system gnu)
- #:use-module (gnu packages python)
- #:use-module (gnu packages xml))
-
-(define-public yasm
- (package
- (name "yasm")
- (version "1.3.0")
- (source
- (origin
- (method url-fetch)
- (uri (string-append "http://www.tortall.net/projects/yasm/releases/yasm-"
- version ".tar.gz"))
- (sha256
- (base32
- "0gv0slmm0qpq91za3v2v9glff3il594x5xsrbgab7xcmnh0ndkix"))))
- (build-system gnu-build-system)
- (inputs
- `(("python" ,python-wrapper)
- ("xmlto" ,xmlto)))
- (home-page "http://yasm.tortall.net/")
- (synopsis "Rewrite of the NASM assembler")
- (description
- "Yasm is a complete rewrite of the NASM assembler.
-
-Yasm currently supports the x86 and AMD64 instruction sets, accepts NASM
-and GAS assembler syntaxes, outputs binary, ELF32, ELF64, 32 and 64-bit
-Mach-O, RDOFF2, COFF, Win32, and Win64 object formats, and generates source
-debugging information in STABS, DWARF 2, and CodeView 8 formats.")
- (license (license:non-copyleft "file://COPYING"
- "See COPYING in the distribution."))))