aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2014-05-17 15:41:56 +0200
committerLudovic Courtès <ludo@gnu.org>2014-05-17 16:23:01 +0200
commit14af289ed9828850ceb341679e42aaa5db7912ee (patch)
tree9c1709425aba494d5b7f79c1f322ade61bbfc4be
parent1634c0420e5e8e609f5d52f5bf92eeafff5bfb6a (diff)
downloadguix-14af289ed9828850ceb341679e42aaa5db7912ee.tar
guix-14af289ed9828850ceb341679e42aaa5db7912ee.tar.gz
build: Add --with-libgcrypt-libdir=DIR to support Debian's multi-arch layout.
* configure.ac: Remove 'LIBGCRYPT_PREFIX' and use 'LIBGCRYPT_LIBDIR' instead. Add --with-libgcrypt-libdir=DIR option. * Makefile.am (AM_DISTCHECK_CONFIGURE_FLAGS): Pass '--with-libgcrypt-libdir'. * config-daemon.ac: Honor $LIBGCRYPT_LIBDIR when computing LIBGCRYPT_LIBS.
-rw-r--r--Makefile.am1
-rw-r--r--config-daemon.ac12
-rw-r--r--configure.ac20
3 files changed, 31 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index a08215ef1e..84f8eb1b63 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -259,6 +259,7 @@ endif BUILD_DAEMON
ACLOCAL_AMFLAGS = -I m4
AM_DISTCHECK_CONFIGURE_FLAGS = \
--with-libgcrypt-prefix="$(LIBGCRYPT_PREFIX)" \
+ --with-libgcrypt-libdir="$(LIBGCRYPT_LIBDIR)" \
--with-nix-prefix="$(NIX_PREFIX)" \
--enable-daemon
diff --git a/config-daemon.ac b/config-daemon.ac
index 08a72a0c4c..a13525a7f5 100644
--- a/config-daemon.ac
+++ b/config-daemon.ac
@@ -38,13 +38,21 @@ if test "x$guix_build_daemon" = "xyes"; then
case "$LIBGCRYPT_PREFIX" in
no)
LIBGCRYPT_CFLAGS=""
- LIBGCRYPT_LIBS=""
;;
*)
LIBGCRYPT_CFLAGS="-I$LIBGCRYPT_PREFIX/include"
- LIBGCRYPT_LIBS="-L$LIBGCRYPT_PREFIX/lib -lgcrypt"
;;
esac
+
+ case "$LIBGCRYPT_LIBDIR" in
+ no)
+ LIBGCRYPT_LIBS="-lgcrypt"
+ ;;
+ *)
+ LIBGCRYPT_LIBS="-L$LIBGCRYPT_LIBDIR -lgcrypt"
+ ;;
+ esac
+
AC_SUBST([LIBGCRYPT_CFLAGS])
AC_SUBST([LIBGCRYPT_LIBS])
diff --git a/configure.ac b/configure.ac
index 05e0370e6b..7b2a0e4dd5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -116,19 +116,39 @@ AC_ARG_WITH([libgcrypt-prefix],
yes|no)
LIBGCRYPT="libgcrypt"
LIBGCRYPT_PREFIX="no"
+ LIBGCRYPT_LIBDIR="no"
;;
*)
LIBGCRYPT="$withval/lib/libgcrypt"
LIBGCRYPT_PREFIX="$withval"
+ LIBGCRYPT_LIBDIR="$withval/lib"
;;
esac],
[LIBGCRYPT="libgcrypt"])
+AC_ARG_WITH([libgcrypt-libdir],
+ [AS_HELP_STRING([--with-libgcrypt-libdir=DIR],
+ [search for GNU libgcrypt's shared library in DIR])],
+ [case "$withval" in
+ yes|no)
+ LIBGCRYPT="libgcrypt"
+ LIBGCRYPT_LIBDIR="no"
+ ;;
+ *)
+ LIBGCRYPT="$withval/libgcrypt"
+ LIBGCRYPT_LIBDIR="$withval"
+ ;;
+ esac],
+ [if test "x$LIBGCRYPT" = x; then
+ LIBGCRYPT="libgcrypt"
+ fi])
+
dnl Library name suitable for `dynamic-link'.
AC_MSG_CHECKING([for libgcrypt shared library name])
AC_MSG_RESULT([$LIBGCRYPT])
AC_SUBST([LIBGCRYPT])
AC_SUBST([LIBGCRYPT_PREFIX])
+AC_SUBST([LIBGCRYPT_LIBDIR])
GUIX_ASSERT_LIBGCRYPT_USABLE