aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-05-10 00:54:15 +0200
committerjgart <jgart@dismail.de>2024-07-16 02:17:59 -0500
commit14026b52204ba947fdd5dcaff0d9bc263b6b2b18 (patch)
treef93bec90ad4415e6e444b16e617474cfd12de5a0
parentb91353f372dbbccdb98d6407739841a2863067dd (diff)
downloadguix-14026b52204ba947fdd5dcaff0d9bc263b6b2b18.tar
guix-14026b52204ba947fdd5dcaff0d9bc263b6b2b18.tar.gz
gnu: python-pytest-trio: Move to pyproject-build-system.
* gnu/packages/python-check.scm (python-pytest-trio): [build-system]: Move to pyproject-build-system. [arguments]: Move from <#:phases> to <#test-flags>. Change-Id: I7653110fc299d0757f7e01c2c1c29d599cb206bf Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Signed-off-by: jgart <jgart@dismail.de>
-rw-r--r--gnu/packages/python-check.scm25
1 files changed, 10 insertions, 15 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index d79427f28a..cb46af3490 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -1225,22 +1225,17 @@ simpler.")
(uri (pypi-uri "pytest-trio" version))
(sha256
(base32 "0c8cqf9by2884riksrqymqfp2g1d2d798a2zalcw9hmf34c786y0"))))
- (build-system python-build-system)
+ (build-system pyproject-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? inputs outputs #:allow-other-keys)
- (when tests?
- (add-installed-pythonpath inputs outputs)
- (invoke "pytest" "-W" "error" "-ra" "-v" "--pyargs"
- "pytest_trio" "--verbose" "--cov" "-k"
- (string-append
- ;; Needs network
- "not test_async_yield_fixture_with_nursery"
- " and not test_try"
- ;; No keyboard interrupt in our build environment.
- " and not test_actual_test"))))))))
+ (list
+ #:test-flags '(list "-W" "error" "-ra" "-v" "--pyargs"
+ "pytest_trio" "--verbose" "--cov" "-k"
+ (string-append
+ ;; Needs network
+ "not test_async_yield_fixture_with_nursery"
+ " and not test_try"
+ ;; No keyboard interrupt in our build environment.
+ " and not test_actual_test"))))
(native-inputs
(list python-hypothesis python-pytest python-pytest-cov))
(propagated-inputs