aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2024-05-28 00:33:02 +0200
committerLudovic Courtès <ludo@gnu.org>2024-08-31 10:45:25 +0200
commit11d0061108bd85da8064929b00373b26cf465bbe (patch)
treec498b36747222ac24a48ca2aa33e8e9429bd25b0
parentcde7374a9eaf0f6ab80cc9dac353892c9bf44245 (diff)
downloadguix-11d0061108bd85da8064929b00373b26cf465bbe.tar
guix-11d0061108bd85da8064929b00373b26cf465bbe.tar.gz
gnu: Add texlive-tpic2pdftex-bin.
* gnu/packages/tex.scm (texlive-tpic2pdftex-bin): New variable. (texlive-tpic2pdftex)[propagated-inputs]: Add TEXLIVE-TPIC2PDFTEX-BIN. Change-Id: I8b48c82c8df632c8bbe2d0aac76f1a7421116c2b
-rw-r--r--gnu/packages/tex.scm47
1 files changed, 47 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 3e2c194a91..7bd16cb17f 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -45787,6 +45787,7 @@ is planned.")
"02nf2fg4xzh8lbbddvm44qyvcvfn5b7kzcyg729a58l29gd88pbs")))
(outputs '("out" "doc"))
(build-system texlive-build-system)
+ (propagated-inputs (list texlive-tpic2pdftex-bin))
(home-page "https://ctan.org/pkg/tpic2pdftex")
(synopsis "Use @code{tpic} commands in pdfTeX")
(description
@@ -45794,6 +45795,52 @@ is planned.")
@code{.PS} and @code{.PE} markers), to @code{\\pdfliteral} commands.")
(license license:gpl3+)))
+(define-public texlive-tpic2pdftex-bin
+ (package
+ (inherit texlive-bin)
+ (name "texlive-tpic2pdftex-bin")
+ (source
+ (origin
+ (inherit texlive-source)
+ (modules '((guix build utils)
+ (ice-9 ftw)))
+ (snippet
+ #~(let ((delete-other-directories
+ (lambda (root dirs)
+ (with-directory-excursion root
+ (for-each
+ delete-file-recursively
+ (scandir "."
+ (lambda (file)
+ (and (not (member file (append '("." "..") dirs)))
+ (eq? 'directory (stat:type (stat file)))))))))))
+ (delete-other-directories "libs" '())
+ (delete-other-directories "utils" '("tpic2pdftex"))
+ (delete-other-directories "texk" '())))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments texlive-bin)
+ ((#:configure-flags flags)
+ #~(cons* "--enable-tpic2pdftex" (delete "--enable-web2c" #$flags)))
+ ((#:phases phases)
+ #~(modify-phases #$phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion "utils/tpic2pdftex"
+ (invoke "make" "check")))))
+ (replace 'install
+ (lambda _
+ (with-directory-excursion "utils/tpic2pdftex"
+ (invoke "make" "install"))))))))
+ (native-inputs '())
+ (inputs '())
+ (propagated-inputs '())
+ (home-page (package-home-page texlive-tpic2pdftex))
+ (synopsis "Binary for @code{texlive-tpic2pdftex}")
+ (description
+ "This package provides the binary for @code{texlive-tpic2pdftex}.")
+ (license (package-license texlive-tpic2pdftex))))
+
(define-public texlive-tqft
(package
(name "texlive-tqft")