aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-25 22:47:08 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-25 22:58:28 +0100
commit1129b6fe4ab6faf2ae89093d0c8c92f66de5696b (patch)
treed509ed9d33a01a4188541ef0758990d912986fad
parent86ee57e861bd729d31c3ce8a0ccdc77035f841b5 (diff)
downloadguix-1129b6fe4ab6faf2ae89093d0c8c92f66de5696b.tar
guix-1129b6fe4ab6faf2ae89093d0c8c92f66de5696b.tar.gz
gnu: yggdrasil: Enable tests.
* gnu/packages/networking.scm (yggdrasil): Enable tests. [arguments]: <#:phases>: Use custom 'check phase. Change-Id: Ia2a59803508063a97993eae647a66335f5db3d06
-rw-r--r--gnu/packages/networking.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 6aebdb0a54..b22a755396 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -4635,8 +4635,6 @@ QUIC protocol.")
(build-system go-build-system)
(arguments
(list #:import-path "github.com/yggdrasil-network/yggdrasil-go"
- ;; TODO: figure out how tests are run
- #:tests? #f
#:install-source? #f
#:phases
#~(modify-phases %standard-phases
@@ -4655,7 +4653,12 @@ QUIC protocol.")
#:import-path directory))
(list "github.com/yggdrasil-network/yggdrasil-go/cmd/yggdrasil"
"github.com/yggdrasil-network/yggdrasil-go/cmd/yggdrasilctl"
- "github.com/yggdrasil-network/yggdrasil-go/cmd/genkeys"))))))))
+ "github.com/yggdrasil-network/yggdrasil-go/cmd/genkeys")))))
+ (replace 'check
+ (lambda* (#:key tests? import-path #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion (string-append "src/" import-path)
+ (invoke "go" "test" "-v" "./cmd/..." "./src/..."))))))))
(propagated-inputs
(list ;; go-golang-org-x-mobile ; Not packed yet, for contrib.
;; go-golang-zx2c4-com-wireguard-windows ; Not packed yet, for tun.