aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-07 17:18:58 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-07-18 10:45:21 +0800
commit0ece738474b82082a1f2a2cd2ae2bc31d99de9a4 (patch)
tree3dceeb4fe942362ba6ed9b4fc0285eafe0488a8c
parent9c58e9538ca2a4c160dd62f803a7e07212ac30b1 (diff)
downloadguix-0ece738474b82082a1f2a2cd2ae2bc31d99de9a4.tar
guix-0ece738474b82082a1f2a2cd2ae2bc31d99de9a4.tar.gz
gnu: Add mpvqt.
* gnu/packages/kde-plasma.scm (mpvqt): New variable. Change-Id: I9d370a780f9088541a63c94c7a4ac017d1cc57fe
-rw-r--r--gnu/packages/kde-plasma.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/kde-plasma.scm b/gnu/packages/kde-plasma.scm
index 78a178d321..368519b92f 100644
--- a/gnu/packages/kde-plasma.scm
+++ b/gnu/packages/kde-plasma.scm
@@ -1790,6 +1790,32 @@ KF5/Qt5 to KF6/Qt6")
is controllable via voice or TV remote.")
(license license:gpl2+)))
+(define-public mpvqt
+ (package
+ (name "mpvqt")
+ (version "1.0.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://kde/stable/mpvqt/"
+ name "-" version ".tar.xz"))
+ (sha256
+ (base32
+ "1fafyn3a8hgg1g3nfka6hyynlmqdygaxz0fhp4ckxwz54nlx4cci"))))
+ (build-system qt-build-system)
+ (native-inputs
+ (list extra-cmake-modules pkg-config))
+ (inputs
+ (list qtdeclarative))
+ (propagated-inputs
+ (list mpv))
+ (arguments
+ (list #:qtbase qtbase))
+ (home-page "https://invent.kde.org/libraries/mpvqt")
+ (synopsis "A libmpv wrapper for QtQuick2 and QML")
+ (description "This package provides a libmpv wrapper for QtQuick2 and QML.")
+ (license license:lgpl2.1+)))
+
(define-public plasmatube
(package
(name "plasmatube")