aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-12-15 14:24:25 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-12-15 15:38:52 +0100
commit0dd4b7d73278ca0b90b2b74f8e64eb86fbb69d69 (patch)
tree77520b17a42aa196d727e0bacb155eb14da15120
parentdbfce8ff5b76700da34753d302f8aae0a2c114c4 (diff)
downloadguix-0dd4b7d73278ca0b90b2b74f8e64eb86fbb69d69.tar
guix-0dd4b7d73278ca0b90b2b74f8e64eb86fbb69d69.tar.gz
gnu: Add r-flowviz.
* gnu/packages/bioconductor.scm (r-flowviz): New variable.
-rw-r--r--gnu/packages/bioconductor.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 65ce365eef..cbb79da2d1 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -5405,6 +5405,35 @@ and some custom layers also make it easy to add gates and population
statistics to the plot.")
(license license:artistic2.0)))
+(define-public r-flowviz
+ (package
+ (name "r-flowviz")
+ (version "1.50.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "flowViz" version))
+ (sha256
+ (base32
+ "0ik16bxcfcg3q26ra3055718kskid64aaazcbqsxalca9ppdm4k7"))))
+ (properties `((upstream-name . "flowViz")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biobase" ,r-biobase)
+ ("r-flowcore" ,r-flowcore)
+ ("r-hexbin" ,r-hexbin)
+ ("r-idpmisc" ,r-idpmisc)
+ ("r-kernsmooth" ,r-kernsmooth)
+ ("r-lattice" ,r-lattice)
+ ("r-latticeextra" ,r-latticeextra)
+ ("r-mass" ,r-mass)
+ ("r-rcolorbrewer" ,r-rcolorbrewer)))
+ (home-page "https://bioconductor.org/packages/flowViz/")
+ (synopsis "Visualization for flow cytometry")
+ (description
+ "This package provides visualization tools for flow cytometry data.")
+ (license license:artistic2.0)))
+
(define-public r-flowsom
(package
(name "r-flowsom")